Coppermine?

software development

#1

Having given up on getting Gallery up and running (awaiting a response to my query about that on the forums), I decided to give Coppermine a try. I get further in it that I do in Gallery, but I still hit some snags in configuration.

First: “Could not create a mySQL connection, please check the SQL values entered. MySQL error was : Can’t connect to local MySQL server through socket ‘/var/run/mysqld/mysqld.sock’ (111)”

and Secondly:“The installer can not find the ‘/usr/bin/X11/convert /’ directory you have specified for ImageMagick or it does not have permission to access it. Check that your typing is correct and that you have access to the specified directory.”

Any ideas?


#2

Ok, let me clarfiy that last query. I see what I was doing as it pertains to the mysql (I think). But the error with ImageMagic persists:

“Warning: stat failed for /usr/bin/X11/convert/ (errno=20 - Not a directory) in /home/.cloris/elis/elisabethepps.com/coppermine/install.php on line 83”

and then:

“The installer can not find the ‘/usr/bin/X11/convert/’ directory you have specified for ImageMagick or it does not have permission to access it. Check that your typing is correct and that you have access to the specified directory.”

What am I doing wrong? Based on other posts in the support forum in reference to “Gallery” I ascertained that I was to use ‘/usr/bin/X11/convert/’ where it asks for “ImageMagick path”. Am I incorrect?


#3

I think I needed to create an .htaccess file in my gallery directory. It has a single line:

AddType php-cgi .php

I think after that the install script found ImageMagick.


#4

/usr/bin/X11/convert is an executable file, not a directory. The error message aboves indicates that the path is not to a directory.

Does the Coppermine configuration ask for a directory or file for ImageMagick ?


#5

Hmm, I am not sure about the semantics… it asks specifically for “ImageMagick path”. How should I adjust what I inputed to properfly fill that request?

Thank you.


#6

Ok, we are talking about Gallery now, not Coppermine? I apologize for my ignorance, but you’ll have to tell me if what I did was correct or not. Specifically:

I used notepad to create a file that only reads “AddType php-cgi .php”, saved it as “.htaccess”, and uploaded it via WS_FTP set to ASCII into my “gallery” directory. Is that right?

Apparently I did it wrong, because it now introduces a whole slew of error messages where previously gallery had reported success:

“Warning! Apache is not obeying your .htaccess file. Try entering the following into your web server’s httpd.conf file:
<Directory /home/.cloris/elis/elisabethepps.com/gallery>
AllowOverride Options FileInfo

and

“Warning! Magic quotes are on. Your webserver owner can turn them off by putting:
magic_quotes_gpc = Off
in your php.ini file”

Neither one of these error messages existed before I uplaoded that .htaccess I created (possibly erroneously). In my last attempt at installing gallery, both of those lines had reported success. Nothing has changed since then other than the new .htaccess file.

I fear I have now screwed things up even further…


#7

It may be all the path you need to specify is /usr/bin/X11

I don’t think you want to reference the executable directly; the script just needs to know which directory to look in for it.

I wonder how your setup is different than mine? I doubt the ‘exploding’ install failure will cause any problems. You can probably just rename the .htaccess file to take it out of the picture for a bit until/unless you need it again. I think I needed it because even though my path pointed to the X11 directory just fine the script didn’t have permission to execute it. I’m just guessing. My sincere apologies if I’ve led you astray. Blind leading the blind I guess.


#8

Ok, as for Coppermine, this time I just entered “/usr/bin/X11”, and the new error message is:

"The installer found the ImageMagick ‘convert’ program in ‘/usr/bin/X11/’, however it does not seem to work or it can’t be executed.

Using phpinfo, check that the ‘exec’ function is not in the list of functions that have been disabled by the administrator (disable_functions directive).

Using the command line try to execute the ‘convert’ program and checks that it works correctly.

If ‘exec’ was disabled by your administrator and you can’t change that you will need to use GD. To try to use GD, clear the path you have entered for ImageMagick."

I am very confused though. When you talk about this “.htaccess” file, are you talking about needing it to run Coppermine or to run Gallery? As for gallery, I haven’t ever entered anything related to the “X11”- I got so many errors with Gallery I just gave up. Were you saying I need to upload the .htaccess for Coppermine?


#9

Well,what I wound up doing was following it’s last directive and clearing the Image Magick path. I seem to be able to get everything running with GD, I just am frustrated that I couldn’t do the same with IM…


#10

I’m talking coppermine only. I’ve never messed with Gallery.

I think you are --><-- this close to getting it running with IM.

From your error message it sounds like the script now finds IM ok, but won’t execute the ‘convert’ command. I believe it is because users have permissions to run some commands, but not scripts. CGI runs as a user (you) on Dreamhost but I don’t think PHP does. I believe this is why you need the .htaccess. I had the same issue and for me, the .htaccess file fixed it. I believe this is called ‘running php as cgi’ or similar. There is an article about running php as cgi in the knowledge base. Basically you can either rename a bunch of files ‘.pcgi’ (or something similar) or just give the whole directory permissions to run php scripts as if they were a cgi. For me, the .htaccess approach was simpler.

I am using other php scripts that require this too, for example pMachine requires the same .htaccess file its script directory in order for the file manager to read/write files.


#11

Yes. I misunderstood your earlier instruction… where you said to upload the .htaccess file into my “gallery” directory I did that for my (literal) “Gallery” directory- since I have no directory named “gallery” for Coppermine.

Enough about what I did wrong- apparently now I have done something right. (whew) I uploaded the .htaccess to Coppermine, got the ImageMagick to execute, and the entire app now seems to run just fine.

Thank you immensely for your (quick! generous!) help!


#12

TAKE NOTE:

I am 99.9% sure that the the ImageMagic install is located here: /usr/bin/convert

This is different than the standard install location. If you change the path information (i.e. remove the “X11”) you should be good as far as the location of ImageMagic.


#13

Not on my machine, vega. Still on Debian Potato if that makes a difference.

[vega]$ whereis convert convert: /usr/X11R6/bin/convert /usr/bin/X11/convert I would say try using whereis convert from the shell and see where convert is on your machine.

It’s a bit confusing - “ImageMagickTM 5.5.2 is a robust collection of tools and libraries” and maybe it would help if the installation for things really just asked for the path to the convert file since there is no file or directory named ImageMagick (not including source).


#14

I’m not sure… I did get it working with “usr/bin/X11”, once I uploaded the .htaccess file, that is.


#15

thanks guys…I had the same problem, and the .htaccess file fixed it!


To err is human, but to really stuff up requires a computer.


#16

I’m running Coppermine on one of my sites. I specified ‘GD Version 2.x’ for the resizing methods and left the ImageMagick path blank.