Content-MD5 header


I can’t seem to get this header included. I’ve tried including “ContentDigest On” in the directory’s .htaccess file. Apparently this isn’t enough. (The various docs say it only works in Apache’s “core” module. I’ve tried some things but I’m not sure how to ensure that only the core module is processing things.)

Anybody happen to know how to get this turned on?


What type of pages are you trying to get this to work on? It only works for static files — PHP scripts, for instance, will have to generate a Content-MD5 header themselves.


Yeah, I figured that would be the case with php files. I’ve been trying with html and txt files. For txt files, this is what the response headers look like:

Date Sat, 05 Jun 2010 00:37:40 GMT Server Apache Last-Modified Sat, 05 Jun 2010 00:31:53 GMT Etag "f68c02e-0-4883d90f1f040" Accept-Ranges bytes Vary Accept-Encoding Content-Encoding gzip MS-Author-Via DAV Content-Length 20 Keep-Alive timeout=2, max=100 Connection Keep-Alive Content-Type text/plain

(These isn’t the literal header; it’s copied from Firebug’s output.)


The MS-Author-Via header is … unusual. Do you have WebDAV turned on for this directory? If so, try turning it off.


I had turned it on for another directory. I guess this is spillover from having it enabled at all. I turned it off and it seems to make no difference (aside from no longer having the MS-Author-Via header).