Contact form doesn't work



I have wordpress on my site. I’ve tried Jetpack, Contact Form 7, and a few others. I can’t get any of them to work.

I followed these directions:

It still doesn’t work, even though Contact Form 7 is showing the message that says the message was successfully sent. I don’t really care which contact form I use. Will someone please help me out? Thanks!


If you followed the instructions you linked you should be sending from a valid address on your dreamhost account. What’s domain is the To:? If it’s gmail, aol or Comcast change to something else. Another thing you can try if your not already is sending To your valid dreamhost account, even if that’s not the best for you at least try it for testing.


Yes, I am sending FROM a valid address on my domain. I’ve been trying to send TO a Yahoo email account.

Per your recommendation, I tried setting the TO and FROM to the same email address on my domain. This does work. Yay! So, I tried creating a ‘forward only’ email address on my domain, set to forward to my Yahoo account. I set my TO email to my forward option and the FROM email to the original email on my domain. I never get the email in my Yahoo account. Any ideas? I tried sending an email from my email client to the forward address, and never got it either. Does Dreamhost not like Yahoo?

At least I have the contact form working - Thank you! But I’d rather not have to check yet another email address, so I welcome any ideas.


Welcome to the world of RBL or Real Time Blacklists.

Whatever server is sending your mail is blacklisted somewhere. You can check full headers, and use to verify.

You could open a ticket with support, but it will fall into a black hole where you will either get no reply or one that will say your tickets in the hands of those that deal with RBL’s and to save time there will be no further updates.

If you’re no currently sending via an SMTP server address (i.e. sending via phpmail) you can switch to the SMTP server for your mail account, and that will probably work.

Best way, to make sure you never miss an email, leave it sending from and receiving to the same dreamhost account.