Connecting to Dreamobjects via Synology




I have a Synology Diskstation (DS213J) and it allows S3 connections to Amazon S3, Microsoft Azure, CHT Hicloud S3, and SFR Stockage. I have tried these options to connect to Dreamobjects (including changing the IP Address for Amazon S3 so it points to Dreamobjects. I can provide my Access and Secret Keys and can see the buckets but cannot connect.

I was wondering if anyone has managed to connect to Dreamobjects using the Synology so that it can schedule regular backups of files.




Hi Craig,

We’ve asked Synology to offer a configurable hostname for their S3 backup but have never received a favorable reply. It’s interesting that you were able to list your buckets but not perform a backup. I’ll take a look and see if we’ve got a Synology around here that I can test with. I’ll let you know what I find out.



Hi Justin,

Thanks for the reply. Thought I would provide some extra details on what I’ve done to “trick” the Synology NAS to think I’m backing up to the Amazon AWS server.

I logged onto the NAS using SSH root@IP and redirect the Amazon S3 hostname to the DreamObjects IP reference-style link. I then added a new line to /etc/hosts file as follows.

echo “” >> /etc/hosts

Once this was done I was able to log into the NAS and then attempt to backup using the Amazon S3 Backup Destination.

The items required to be filled in are as follows:

Backup Name: Just entered a copy name for this backup job, e.g Test1
Access Key: Copied from Dreamobjects User Management
Secret Key: Copied from Dreamobjects User Management

Once I entered the two keys I was able to select the buckets from the dropdown list. This connected to DreamObjects as the two buckets available for selection were the two buckets I have created.

I was then able to select the source folder that I wanted to backup. After clicking next the system appeared to be connecting to DreamObjects however the following message appeared.

Failed to access the backup destination.

Hope this provides some additional information for you.



Hey Craig,

Here’s what I’ve found so far. It makes sense that you’re able to list the buckets in your DreamObjects account by overriding the hostname. It looks to me that when you select a bucket and try to perform the backup job, it’s trying to backup using the subdomain calling format -> It then has to look up the subdomain uses AWS DNS servers and I believe that’s why it’s failing.

I’d recommend adding another line to your hosts file that includes the name of your bucket. That is, do this and replace “my-bucket” with the name of the bucket you want to use for backups:

echo “” >> /etc/hosts

Give that a try and let us know if it works.


Hmm, thinking about it, I’m not sure that’s going to fix it either. Adding that line to /etc/hosts will redirect the request for the Amazon S3 bucket to DreamObjects, but the request will still arrive with the Amazon hostname, so I’m not sure the DreamObjects server will honor that? (Unless we’ve set it up specifically to handle that type of request, which I suppose is possible.)


I was able to get ahold of a Synology and tried this out. I was able to see my buckets but unable to performa a backup. I received a different error though.

“Connection test failed. Please check your authentication information.”

As Andrew mentioned, it’s likely a problem since the Amazon endpoint would be used. That’s also likely to cause an error in the signing of the request.