Connect to MySQL from DreamWeaver

apps

#1

Hi!
I want to work on my Wordpress blog from a locally installed copy of Dreamweaver 8. (This should be possible - there are others doing this with other hosts.)

I specifically want to be able to use the ‘design view’ in
Dreamweaver, which lets you visually see how things come out as you code.

In order to do this, a remote connection from Dreamweaver to Dreamhost is required.

I have spent 4 hours trying to complete the connection.
I really have to ask for help now - I seem to be stuck!

*Blog URL: www.vikingprincess.net.
*‘mysql’ database name: ‘johanna’ uid-jojo0507;pw-sverige (will change those very shortly now, but just in case somebody sees this and can help me with the parameters)

*I am currently working on changing the ‘Tiga’ theme, which is in www.vikingprincess.net/wp_content/themes/tiga

In Dreamweaver 8, I have set up a ‘Site’ (menu option: Site>Manage Sites, create new or edit existing) (I think I must be wrong about one or more of them. See ‘Sites’ dialogue box:

Local Info:

Sitename: vp1
Local Root Folder: d:\website\testenv
Refresh local file list automatically: checked
Default Images Folder: blank
Links Relative to: Document
HTTP Address: http : // www . vikingprincess . net/ (spaces removed)
Case Sensitive Links: unchecked
Cache: checked

Remote Info:

Access: FTP
FTP Host: ftp . vikingprincess . net (remove spaces)
Host Directory: /
Login: jojo0507 - works fine
Password: c$MjgmaA- works fine (this will be changed, shortly - nothing there worth hacking anyway. just hoping that my access problem can be solved.)
Use Passive Mode: checked
Use Firewall: unchecked
Use Secure FTP: unchecked
Maintain Syncronization Info: checked
Automatically Upload Files upon save: checked
Enable File check in and out: unchecked

Testing Server:

Server Model: PHP mysql
Access: FTP
FTP Host: ftp . vikingprincess . net (remove spaces)
Host Directory: /
Login: jojo0507
Password: c$MjgmaA
Use Passive Mode: checked
Use Firewall: unchecked
Use Secure FTP: unchecked
URL Prefix: http : // www . vikingprincess . net/

Cloaking
Enable Cloaking: checked
Cloaked Files end with: unchecked

Design Notes
Site Map Layout
File View Columns
Contribute
The 4 above were not changed from default


THIS (above) is working and LETS ME SYNCH THE FILES WITH THE REMOTE
CONTENT. But I also need a db connection.


So I select Window > Databases and try to set up as follows:

mysql Connection Settings:

Connection Name: vpdb
mysql Server: localhost (I have tried ‘mysql.vikingprincess.net’ as
well with no success. I saw a post with somebody who connected
remotely while using ‘localhost’ in this setting…(?!)
User Name: jojo0507 (the db user name according to the panel)
Password: see above
Database: johanna

The database connection does not work. I get various kinds of messages
depending on what settings I try. With the above settings I get the
message:

"HTTP code 404 file not found. Here are some possible reasons for the
problem: 1) There is no testing server running on the testing machine. 2) The testing server specified does not map to the
http://vikingprincess.net/_mmServerScripts/MMHTTP.php url. Please verify that the URL prefix maps to the root of the site. "

Well I tried every combination of parameters that I could think of and that seems reasonably likely.

I have added my machine IP to the list of computers that jojo0507 is allowed to access the database from (strange setting!)

Please help me - I know I have got something wrong, but what!!!

All the best from London, UK
Johanna