Confusion with subdomain root directory name? Or worse


#1

Well… I’m kind of hoping that’s what the problem is, anyway…

Here’s what happened: I set up a 2nd WP blog as a subdomain. (The other one is a regular domain.) I did the one-click install. Everything seemed to be going just fine. It showed up, and so did the new theme, and so did all the ftp files. Then I did something I’ve done before with no problems-- downloading all of the files to Dreamweaver in order to change a jpg file and reupload it. It worked really well before, and actually, the download part worked perfectly this time too. In the server setup, I listed it as ourblog.greenhillslawnandgarden.com/. The full domain root directory name (which works in DW in its own server config) is greenhillslawnandgarden.com.

HOWEVER, for the ourblog setup (when I tried to reupload the changed jpg file-- this is what worked before with the regular domain in its own server setup, remember), DW informed me that
an FTP error had occurred and that access was denied. “File activity incomplete. 1 file(s) or folder(s) were not completed.Make sure you have proper authorization on the server and the server is properly configured.” I might be thinking that this is a DW problem, except that everything works perfectly with the other domains and their server configurations. Also, I know that the Dreamhost FTP password is correct, because DW doesn’t let you go ahead with your server setup if it isn’t. The only thing I can think of that is different is that this is a subdomain. I tried to find questions/answers about this in a search in the forums, but I couldn’t find exactly the same issue. Does anyone know if this really is the problem (somehow the
root directory name for a subdomain isn’t the same format, needs to be entered differently, etc.?) Or is it some horrible unbelievably complicated thing involving WP and…?.. and… ???.. instead? =O


#2

the path to your subdomain is /home/USER/ourblog.greenhillslawnadgarden.com
the full domain root is ourblog.greenhillslawnandgarden.com


#3

That’s what I’ve been using (the full domain root.) I keep getting “An FTP error occurred. Cannot open server folder ourblog.greenhillslawnandgarden.com. Access denied. The file may not exist, or there could be a permission problem.” (But it IS there in the ftp index on Dreamhost… .I’m trying to think of everything!) I just tried reuploading a file to the site associated with the main domain root (greenhillslawnandgarden.com) to see if it was a more general problem, and everything worked perfectly for the domain itself. That’s why I wondered if it had something to do with the subdomain… I’ve really tried to find an answer for this somewhere, but no luck so far!

ETA:

I’m also having an impossible time with replacing the header image in the Coraline theme in WP. I keep getting this error message:

“Unable to create directory /home/catdan/ourblog.greenhillslawnandgarden.com/wp-content/uploads/2012/02. Is its parent directory writable by the server?”

So I’m thinking that maybe this is part of the same exact problem? I’m asking over there too.

Efurther TA:

Is this something where I need to change permissions? (is afraid)

Thank you to everybody for advice and patience and help! :slight_smile: