Config for New Uber Uploader

apps

#1

I looked on this forum, but can’t find anything that can help me solve my problem with Uber Uploader - http://uber-uploader.sourceforge.net/

I’ve attempted more configuration options that you can imagine and can’t get anything but flength errors and “Failed to create temp_dir” errors. Anyone have any insight they can share? An updated config file for a more current version?

I had this working for months with the older uu_ prefixed version. I updated and am having no luck.

Thanks


#2

Hmmmm…uber uploader. Hopefully someone here has used the latest version.

I think I hear the pitter patter of rlparker’s and Lensman’s feet approaching. :smiley:

-Scott


#3

If you post what version are you having difficulty installing, I’ll try to take a look at it later today and see if I can’t produce a “working” example config file.

In the mean time, have you looked at the uber-uploader forums? It seems that your problem might be related to this post :wink:

–rlparker


#4

6.3.1, the newest latest.

By the way, I saw the thread you contributed to earlier, but couldn’t get over the hurdles. I’m thinking maybe we could figure this out and post a tutorial to the wiki. I’m willing to do some screenshots or something if we can figure out a good instruction set.


#5

and I tried what was suggested in that forum - no change. thanks though.


#6

I just checked and I have not upgraded uber-uploader since 6.1 (and 6.3.1 is now current) so later today I will do the upgrade and get back with you with any problems I encounter and (hopefully) a copy of my “working” config file. :wink:

–rlparker


#7

I have not used this uber thingy so I was tempted to try :wink: .

I think it is working okay. It looks like the screenshot on the sourceforge page.

What details do you want? I will pm them to you.


Norm

Opinions are my own views, not DreamHosts’.
I am NOT a DreamHost employee OK!! :@

You act on my advice at your own risk!


#8

how about how you set up:

ubr_upload.pl

ubr_default_config.php

ubr_ini.php

Thanks!


#9

They are in a pm I sent to you.

I hope!


Norm

Opinions are my own views, not DreamHosts’.
I am NOT a DreamHost employee OK!! :@

You act on my advice at your own risk!


#10

Yea Norm! I just got a chance to sit down at my computer again after having been pulled away for “weekend chores” (the un-ending “Honeydew list” - "Honey, please do this … and this… and this…) ans was getting ready to attack this but find you have it covered. Hooray! :slight_smile:

–rlparker


#11

I could not resist it. It was beckoning to me.
Quite a useful doo-dah. :slight_smile:


Norm

Opinions are my own views, not DreamHosts’.
I am NOT a DreamHost employee OK!! :@

You act on my advice at your own risk!


#12

Norm, I haven’t received an email. Thanks and let me know…


#13

It wouldn’t be an e-mail. It’d be a message here in the forum system. Use the “Check Private” link at the top of this page. This URL might also work:
http://discussion.dreamhost.com/login.pl?Cat=

-Scott


#14

Norm,

Your suggestions were helpful. Still having the same troubles though. I thinking it may be because I have a wordpress install in the root directory of this install? I either continue to get flength errors or the page will redirect to the wordpress 404.

I set it up following your directions on a clean subdomain and it works, thus my suspicion. Any suggestions?


#15

Yep! That’ll screw things up almost every time. WordPress’s default .htaccess file “intercepts” stuff that is not a part of WordPress and redirects it …

The easiest fix is to just use a subdomain, as you have already determined; another approach to take is to modify the WordPress .htaccess to “exempt” the appropriate directories/urls from the WordPress re-direction.

There is a working example of how to do this to facilitate the use of the default DreamHost “stats” subdirectory in the DreamHost Wiki:

http://wiki.dreamhost.com/Making_stats_accessible_with_htaccess

You could use this as a guide to do the same thing for your uber-uploader related urls by modifying it to suit your needs (there are several posts in these forums that discuss modifying this process in this way for other circumstances; you might find those useful).

–rlparker


#16

There is an example .htaccess file in the uber-loader package to overcome the write caching problem that causes the file length error. You could add that to your WordPress .htaccess file.

As rlp says, the WP .htaccess will mess it up everytime.


Norm

Opinions are my own views, not DreamHosts’.
I am NOT a DreamHost employee OK!! :@

You act on my advice at your own risk!


#17

oddly, when I add either what’s recommended for the .htaccess file in the dreamhost wiki for the /stats or on the Uber Upload site, I get a 500 Internal Server Error on the root of the domain and the subfolder i have Uber Uploader in.

This is really becoming epic. I apologize.


#18

I think you may have to place each program in a separate sub-domain or folder as suggested. Clearly the two .htaccessii are having a good fight.

What are you trying to do that needs the two programs in the same folder? Are there any WordPress plugins that you could use to replace uber-uploader?

Or, perhaps you can just add links to the programs once they are installed in their own environments. Since both are PHP scripts they are both open to a bit of changing to fit your needs.

Even if you struggle to adjust the .htaccess file to get them both working there is always the chance that they will be messed up once either WP or U-U are updated. That always seems to be the way. :slight_smile:

Oh, and there is no need to apologise. We have all been there unfortunately.


Norm

Opinions are my own views, not DreamHosts’.
I am NOT a DreamHost employee OK!! :@

You act on my advice at your own risk!


#19

Well, you will need to “merge” the existing .htaccess file for WordPress with the appropriate re-write condition/rule changes to facilitate the uber-uploader integration with WordPress (similar to but not exactly like the “stats” example).

Once this is done, if it is done correctly, you may, or may not, need to use the mod-security disablement via .htaccess suggestion re. the uber-uploader flength error. If you do need to do that, you may be able to do that in a separate .htaccess file, depending upon where you installed uber-uploader. Note that you can accomplish the same thing as that uber-uploader .htaccess fix by disabling “extra web security” for your domain from withing the DH web control panel (Domains -> Manage Domains -> Edit (under the web hosting column for your domain). DreamHost’s “Extra Web Security” is mod_security. :wink:

Of course, as norm1037 correctly points out, you can avoid having to deal with this at all should you just use a subdomain for your uploader.

That said, there is no reason why you should not be able to use WordPress and uber-uploader together if you have them properly configured, and while it might seem “epic” at the moment, I believe the situation is fixable.

Note that you will likely have to account for the cgi-bin directory as well as the uber-uploader directory in the modified rewrite conditions/rules if you used that in your uber-uploader installation. You do not have to even use a cgi-bin on DreamHost (thanks to suEXEC) but then you will have to modify your installation to indicate ubr_uploader.pl’s actually location.

The first place to start to see what is wrong is your error logs - that “500 Internal Server Error” is notoriously useless, as it doesn’t really give any hints as to what caused the error. Looking at your error logs will often provide more clues - the error could be (and often is) something very simple, such as using an improper editor on a perl script, or having a random character or CF/LF in a file.

What does your error log say when the 500 Internal Server Error is displayed?

–rlparker


#20

For what it is worth I just emptied the folder containing Uber-Uploader and then installed WordPress and got that working okay.

I then reinstalled the U-U files and reconfigured the paths (previously I had U-U in a separate folder) and U-U and WP run just fine. I did not make any alterations to .htaccess but left it at the WP installed settings.

I had to change the ubr_upload.pl path though because of the .htaccess rewrite condition set by WP.

So assuming WP is in /home/username/example.com/uber/
and the cgi-bin folder containing ubr_upload.pl is at /home/username/example.com/uber/cgi-bin/

Then I set the ubr_upload.pl as
$PATH_TO_UPLOAD_SCRIPT = ‘/uber/cgi-bin/ubr_upload.pl’;

All the rest was as per my PM to you earlier but of course with the reference to the extra depth of folder (html) removed.

Oh look, version 6.3.2 is out now!!

“When all else fails start again.” :slight_smile:


Norm

Opinions are my own views, not DreamHosts’.
I am NOT a DreamHost employee OK!! :@

You act on my advice at your own risk!