Compiling PHP with a new version of GD?


#1

I am attempting to compile PHP 4.3.8 using GD 2.0.28 (Adds GIF support back to GD).

I have been able to sucessfuly compile GD 2.0.28 and compile PHP 4.3.8. But my problem is that everytime I compile PHP it uses the packaged version of GD (2.0.17) instead of the one I compiled (2.0.28).

I know I should be using the command ‘–with-gd=’ but I dont know what directory should be there. I tried with a number of directorys and all resulted in unsucessfuly builds.

I tried things like:
/home/www.xyz.com
/home/www.xyz.com/
/home/www.xyz.com/local
/home/www.xyz.com/local/
/home/www.xyz.com/bin
/home/www.xyz.com/bin/
/home/www.xyz.com/includes
/home/www.xyz.com/includes/
/home/www.xyz.com/gd-2.0.28
/home/www.xyz.com/gd-2.0.28/

Can anyone tell me what I might be doing wrong?

PS - The error I usally get tells me that it cant find the file gd.h which is in several of those directories I listed above.