Compiling new copy of php4 problem

Ok, I think Im almost there. I downloaded/installed Putty for Windows, enabled ssh for my account. I followed the directions in the wiki and during the installation of the new php in the ssh screen, it keeps timing out at the Says, failed: Connection timed out. Retrying. And it cycles. I closed the SSH session, found an updated link for zlib (.org) that works. I restarted the process by adding the new address to the install script, but for some reason during the installation it continues to come up as .net and stalls. Im thinking its trying to finish the original installation. How do I cancel it and start from scratch? Ive tried closing the session and starting over, but it still wants to look for the .net address. errrrr What do you suggest? btw, someone should update the wiki changing to so others dont run into the same problem.

=> `zlib-1.2.2.tar.gz’
Connecting to[]:80… failed: Connection timed out.

(try: 2) => `zlib-1.2.2.tar.gz’
Connecting to[]:80… failed: Connection timed out.

(try: 3) => `zlib-1.2.2.tar.gz’
Connecting to[]:80…

Ok, I got it to skip the bad url and continue with the installation. However during installation the connection with the server times out and disconnects w/out giving it enough time to complete. Grrrrrrr

Has anyone in here successfully compiled their own version of php4?

Just wondering if this is a lost cause and I should just send in a request to tech support.

If you’re doing the PHP programming yourself, PLEASE PLEASE DO NOT USE PHP4. USE PHP5.

There’s so much crap in PHP4 that just does not make it a viable alternative over PHP5. And PHP6, coming out later this year, is going to be outright removing many things people rely on PHP4 for.
(stuff that was just “disabled” by default in PHP5)

What is the purpose of compiling your own version of PHP4? It’s definatly not to stay uptodate; which is the soul reason I compile my own version of PHP5 – DH is REALLY good at adding all popular and highly requested mods into PHP5.

I need to turn fopen() on!

Thats the only reason. Yes, Im aware that you can use relative paths in php includes, but not for externall sites - only sites hosted on your web space. I have plugins from other sites, and a traffic trading script that relies heavily on the fopen() function, and this darn setting has pretty much disabled all my sites.

What do you recommend? I didnt see anything in the wiki regarding having php5 as an option?

Ok, I was mistaken, its “URL file access” that I need to turn on, not fopen.

allow_url_fopen is security prone, people were improperly including files allowing attacks to include their own remote files which caused a world of problems.

I’d suggest if you are compiling PHP, do PHP5 in any reguards. Here’s the wiki page:

PHP5 is the prefered way to go and when you do this, use the recommeded .ini file, just be sure to turn on register_argc_argv if you want to use Pear. Everything else, by default, is fine.

Just hope none of your scripts require register_globals. That’s my pain of PHP features. I hate it. I dispise it. I yell at anybody that “requries” it. lol

PS: oh yeah and that script they suggest, hum … edit it. DO NOT under ANY circumstances compile anything into $HOME/$DOMAIN/php. REMOVE $DOMAIN !!!
(I really should go and remove that myself. Nobody’s made any comments to that in my “discussion” post on it.)