Cloudflare, -getting a redirection loop

wordpress

#1

After activation of Cloudflare - Free and changing the required www settings.
I realised I had forgotten to change the settings inside of WP.
Unable to set to dashboard I Used phpmysadmin to change the wp-option to add www.
Flushed Cloudflare cache.
Flushed all cookies in browser. (Chrome + Firefox)
waited an hour.

Same issues and when using www.domain.com sent to http://domain.com = the redirect loop
however I can use http://www.domain.com/fr but not http://www.domain.com/en as this alos has redirection loop isuue.

WP Version = 3.7.1 (french) (WP_Lang Fr_fr)
Question Do i just wait for things to age out?
or are there other places I need to change things inside WP’s php or config files?
Thanks inadvance. Anne


#2

You have to change two options.

home
siteurl

Did you change both?


#3

[hr]
Resolved issue.
While Cloudflare was active and using www.domain.com/fr inspected page source & noticed some of the links to pages and content referenced domain.com, but the css and js scripts were all using the www.domain.com.

1, Backup the DB and then disabled Cloudflare (temporary solution while I fix this issue)
2, used SQL UPDATE wp_posts SET guid = replace(guid, ‘http://domain.com’, ‘http://www.domain.com’);
3, used SQL UPDATE wp_posts SET post_content = replace(post_content, ‘http://domain.com’, ‘http://www.domain.com’);
4, used SQL UPDATE UPDATE wp_options SET option_value = replace(option_value, ‘http://domain.com’, ‘http://www.domain.com’) WHERE option_name = ‘home’ OR option_name = ‘siteurl’;

Tested a number of links and content all seems to be OK when using the www.domain.com


#4

FWIW, you only have to change post_content and home/siteURL. The GUID is not nessecary :slight_smile: