Click on a cgi file and retunr to the homepage

wordpress

#1

When i click in a cgi file in this directory “cgi-bin/tgp/init.cgi” to install a script, i return to the homepage…why ?


#2

That’s a good question. But you haven’t told anyone where you got the script from or provided a link to the source. And perhaps you should consult the documentation that came with the script, the web site you got it from, or ask an expert to help you out.

:cool: [color=#6600CC]Atropos[/color] | openvein.org


#3

it’s a CHmod problem, after CHMOD 755 the “tgp” folder now i can install the script…but i have the same problem when i try to eneter in the admin folder.

i have htaccess and htpassword in this folder but i don’t have the login po-pop, i’m redirected to the homepage


#4

Well having .htaccess and .htpasswd doesn’t mean it will work. The contents of the files have to be proper format and accurate. Double check to make sure you didn’t mispell anything or provide the wrong path to the password file. And did you make the .htaccess file yourself, or using the Web Admin Panel, or did another script make it?

:cool: [color=#6600CC]Atropos[/color] | openvein.org


#5

none ?


#6

this is the answer of assistance:

Hello,

DreamHost uses suexec to run cgi scripts. suexec allows Apache to run
CGI
programs using a user id other than that of the Apache process. Suexec
significantly reduces many of the security risks associated with
running
CGIs. Suexec is enabled for DreamHost users, and cannot be disabled.

Because of the way suexec handles security, the directory in which your
CGI scripts live must not be writable by anyone but the CGI user (chmod
755). The scripts themselves must not be writable by anyone but the CGI
user, either. If they are writable, you will receive a 500 error from
Apache.

http://httpd.apache.org/docs/2.0/suexec.html:Apache

Thanks!
Trey


What i must do now ??


#7

the problem is the .htaccess file in the home dir:

BEGIN WordPress

RewriteEngine On RewriteBase / RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d RewriteRule . /index.php [L]

END WordPress

I have permalink structure, when i delete it the script works…but what is problem ?