CI Problem

software development

#1

I installed CodeIgniter (PHP framework), but am only seeing an ERROR 404 instead of a welcome page. I am pretty sure that it is due to PHP path retrieveing something like:

‘/home/{.machineVersion}/{username}/{whatever}’

It should be getting that without that machine version beginning with a period. Is there any way I can get the path without the machine version? realpath() and pathinfo() include that extra directory.


#2

Never mind.

I found out that it wasn’t that issue. Apparently CI requires a ‘?’ be tacked on to the index file.

It has to be 'http://www.sitename.com/index.php?’

Apparently it is an issue only seen with DreamHost.


#3

[quote]It has to be 'http://www.sitename.com/index.php?’
Apparently it is an issue only seen with DreamHost.[/quote]
Do you think it has something to do with PHP running as CGI? Just curious! :slight_smile:

–rlparker


#4

Why would only CI be affected?

I have installed and tried others including CakePHP and Symfony. CI so far is the only one that requires the ‘?’.

Many other forums claim that other hosts have not had a problem with it, and that it was only seen as an issue on DreamHost. Whether thats true or not… I don’t know for sure. But that being said it doesn’t seem as though it would be a CGI issue. I am sure many other hosts run PHP as CGI.

Its not really a huge issue. It’s just a ‘?’.


#5

You are probably right, I was just wondering…and your analysis makes sense. Thanks!
–rlparker


#6

I had a similar (the same?) problem as you - 404 not found on CI install. I fixed it by changing:

$config[‘uri_protocol’] = “AUTO”;

to

$config[‘uri_protocol’] = “PATH_INFO”;

in the config file.

Hope this helps someone :slight_smile:
sig


#7

That is a very useful piece of information that I am sure will be useful to others. Thanks for taking the time to share it! :slight_smile:

–rlparker