Chmod Problem


#1

I have created a new folder under my Domain Folder. I then transferred some Perl files into it.

Now I need to change the permissions on these files however when I try to change the permission on my index.pl file I get this error message. All the other files are changeable without a hitch.
550 Requested action not taken. File unavailable (e.g., file not found, no access).

I am using CuteFTP for my FTP functions.

Can anyone shed any light on this. I have just recently set up my hosting here.


#2

Success, it has to do with Cuteftp and a setting called SIZE. Once it was turned off all worked well.

Cheers


#3

What settings does this apply. I keep trying.

chmod 755 test.pl

with no luck. What does SIZE do?


#4

[quote]What settings does this apply. I keep trying.

chmod 755 test.pl

with no luck.[/quote]
rwxr-xr-x

[quote]What does SIZE do?

[/quote]

Give us your email address. Soon you’ll get some newsletters all about it. :slight_smile:

Actually, tells cuteftp to display file sizes.


#5

Well that doesn’t help. How did you get it working. chmod 755 is good enough for the hosts I’ve used. Even 777 doesn’t work. Do I have to reduce permissions to make it work?


#6

Here is some more documentation:
http://wiki.dreamhost.com/index.php/Perl#Perl_on_Dreamhost


#7

Ok it works. You really need to check that all the modules that you are using are installed.

This perl script works:

#!/usr/bin/perl

use CGI;
my $query= new CGI;

print $query->header;

print “hello people in my head\n”;