CHMOD 755 defaults back to 744-why?

software development

#1

I’m at the end of my rope here; I know cgi scripts need to be chmod’ed to 755 in order to work, but everytime I try to chmod my script through WS FTP pro, it defaults right back to 744! Why is this happening??

I did a chmod 755 on the directory that contains the cgi file, and when I used WSFTP to check it again, the chmod showed the correct number, 755. But when I tried to do the same to the cgi file itself, checking it again revealed that the permissions were only 744, even though WSFTP reported the chmod change to 755 as being successful!

If someone could tell me what I’m doing wrong I would VERY much appreciate it, searches of the knowledge base turn up nothing :frowning:


#2

Have you tried to chmod it through telnetting to your site? It’s pretty easy to do, just go to Start, Run and type in ‘telnet’ and hit enter to bring up the dos (or psuedo-DOS if you’re running Win 2000 or XP) and type o “yoursite.com

You’ll be prompted for your login and password which should be the same as your login/pw to get into the web panel. Type CD “directory name” to enter a directory, when you get to the appropriate directory just type chmod 755 “filename.cgi” and your script should be modded.

Doug


#3

You can also just enter at the DOS/pseudo-DOS/shell prompt:

telnet yoursite.com