Changing Suhosin Settings on php 5.3


#1

I have Wordpress (latest version) installed on my site and I switched to php 5.3 fastcgi in the dreamhost web panel. This resulted in a white screen on my site. Upon looking into this with my theme developer, I come to find out that the problem is suhosin which does not allow stream wrappers. According to them I need to add a line of code to the php.ini file, but I have no idea where this file is or if I am allowed to change it. Could anyone advise? I am not an expert at all of this and I really like my wp theme.


#2

See: http://wiki.dreamhost.com/PHP.ini#PHP_5.3

What exactly needs to be changed, and why does the theme (of all things!) need it?


#3

This is what they told me: “The theme was using the ‘eval()’ php function, but WordPress now forbids the use of it to protect users from malicious code. The developer was forced to change the code to user ‘stream wrappers’ to keep some of the functionalaty of the theme working. Suhosin prevents the use of ‘stream wrappers’ unless you shut that Suhosin option off, or create a whitelist.”

Right now my site is running fine on php 5.2, but if I switch to 5.3 then nothing works. I also could not find the php.ini file to make any modifications. They said to add “suhosin.executor.include.whitelist = bfa://” to that file.[hr]
I looked through that page on changing the settings and I can’t even understand it so I guess I’ll just have to switch themes once I have to upgrade.


#4

In other words, WordPress disallows eval(), so they’re switching to an even more obscure and weird way of hiding what their code is doing? That’s kind of suspicious… I’d avoid that theme.


#5

+1

Toss that theme out before it bites you.


#6

Yeah, I’m beginning to think it’s more trouble than it’s worth. I’m thinking of going with the Catalyst theme. It is a paid theme, but they said they would refund me if it doesn’t work with my host.