Changing Nameservers


#1

I did search the forums, but the directions all seem to point to what I already tried. How are nameservers supposed to be updated? When I make the change either through the Registrations-Modify WHOIS Info, or through the DNS hosting panel, it always seems to revert back to nsx.dreamhost.com.

What am I doing wrong?


#2

You do realize that nameserver changes must propagate? (i.e. it’s not an instant update).

The change needs to be made by logging into the website of whoever the registrar is for the domain in question and updating the nameservers. From there give it 8-24 hours to show up worldwide.


#3

So the initial domains I was trying to work with were .ca domains. Remembering back to some issues I had with another provider, I tried a .net domain, and lo and behold, the WHOIS update worked. So it appears to be a bug/limitation with .ca domains, and perhaps others. At this other provider a year or two ago, they had to go in and make the WHOIS change, it wouldn’t work from the control panel.

Lesson learned: .ca domains are hard (apparently).