Changing my PHP register_globals setting

software development

#1

Hi I need some help…
On my web site I have installed Joomla after I installed it via the dreamhost site it is telling me I need to update my PHP register_globals setting to OFF
"PHP register_globals setting is ON instead of OFF"

How do I do this:
Can I do this via the Joomla gui interface or do I do it from some place else.


#2

On Dreamhost, this indicates that you are running your domain as PHP4 (which has register_global set to “ON” by default). The easiest way to rectify this is to simply change your domain to run PHP5 instead (which has register_globals set to “OFF” by default).

This, or course, presumes that you have no other applications on your site that cannot run under PHP5.

To change you domain to run under PHP5, go to the Control Panel -> Domains -> Manage Domain screen, and click the “edit” link under the Web Hosting column of the relevant domain. From the screen that is presented, indicate that you want to use PHP5 in the check box, and save those setting.

After a few minutes, the domain will be updated to run under PHP5 and your issue will be resolved.

Note that Joomla! will now complain about the Magic_Quotes setting, but that is only a warning, and you can safely ignore it; the Joomla! core code is perfectly safe running with DH’s PHP5 Magic_Quotes setting as it is.

If you have concerns, or more questions, about the magic_quotes issue, just search the forum - it has been discussed here at length. :wink:

–rlparker