Changing File System Permission

apps

#1

Hello,

In installing TatterTools, I confronted with the File System Permission problem and got the following error messages:

File System Permission:

  • Web service configuration file: Cannot create file “.htaccess” in “/dh/cgi-syst”. Change the permission setting of “/dh/cgi-syst” to “0777”
  • Configuration file: Cannot create file “config.php” in “/dh/cgi-syst”. Change the permission setting of “/dh/cgi-syst” to “0777”
  • Attached file directory: Cannot create directory “attach” in “/dh/cgi-syst”. Change the permission setting of “/dh/cgi-syst” to “0777”.
  • Cache directory: Cannot create directory “cache” in “/dh/cgi-syst”. Change the permission setting of “/dh/cgi-syst” to “0777”.
  • Theme Directories: Cannot create directory “customize” in “/dh/cgi-syst/skin”. Change the permission setting of “/dh/cgi-syst/skin” to “0777”.

Is there a way to change the settings of /dh/cgi-syst directory? Where or how can I find that directory in the first place?
I would appreciate any helpful lead.


#2

A simple way is to log into your webdirectory via DH panel --> Domains --> Manages Domains --> WebFTP Once you open your web directory, locate the folder and select “chmod” which on the top right corner.

If you are familiar with shell, you can also do this via shell. But you need to first enable shell access via DH panel --> Users --> Manage Users --> Shell account

Save [color=#CC0000]$97[/color] (max discount) on dreamhost plans by using promo code: [color=#CC0000]97CRAZY[/color]. Sign Up NOW


#3

Uh, /dh/cgi-syst isn’t in his home directory, so he’s not going to be able to CHMOD it.

You’re going to have to adjust the software to install within your home directory (/home/yourusername); if you can’t, then you won’t be able to install it.

emufarmers.com
Very little to do with either emus or farmers!


#4

Hi,

Thanks for your lead. Strangely enough, WebFTP seem to change the permission settings to my likings only to find them back to the default settings when I recheck them right afterwards. When I try to sudo change them using shell, they say they are read-only files… Hm.


#5

as Emufarmers said, if the files reside in /dh, you are not able to do anything as we do not have the right to modify the files there.

Unless you are able to install to /home/yourusername folder, you are able to modify the files.

Save [color=#CC0000]$97[/color] (max discount) on dreamhost plans by using promo code: [color=#CC0000]97CRAZY[/color]. Sign Up NOW