Changing default umask


#1

I have a user who’s uploading directories that are ending up with the permissions of 755. Which means my other users in the group can’t write in those directories. When I do umask for the offending user, it gives me 0002, which I believe defaults to giving me 775 on directories. Is there some other setting that might be overriding this? Is there a way for me to override this?

Thanks, Mark


#2

Would a sticky bit help?
http://wiki.dreamhost.com/Unix_File_Permissions_Cookbook
http://wiki.dreamhost.com/Unix_File_Permissions

-Scott


#3

In addition to the links the Scott provided, you might find this lilnk to have some useful and relevant information:

http://wiki.dreamhost.com/Security

–rlparker


#4

Thanks that just might be the ticket I was looking for