Changed to HTTPS, now can't access site


#1

I have a free SSL certificate, so thought I could change my site to https to make it secure. So In Wordpress I changed the url to https and now I can’t access my admin and the site is still http. It gives an error when I try to access the admin: The requested URL /wp-admin was not found on this server.
Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

Ive changed the wp-config.php file to include the lines of code - define(‘FORCE_SSL’, true);
define(‘FORCE_SSL_ADMIN’,true);

but so far haven’t done anything else. The site is www.farawayfamily.com.

Can anyone help?

thanks


#2

I’m getting a secure version of the dreamhost domain parked kitty at that link.

Sounds like you’ve moved on with your attempts?

When attempting to reinstall wordpress here your going to run into a propagation issue. Changing from parking page to hosted domain DOES create a behind the scenes DNS change. You can’t rush it, you have to wait out the 4 hours.


#3

thanks for the answer, no havent changed anything since my post. I had seen that there was a parked page but didnt realise I just had to wait it out.
[hr]
do i understand from your answer that I have to reinstall wordpress on the secure site? I kind of assumed ti would be migrated somehow when I changed the url within wordpress.


#4

Something is odd. I’m getting the kittycat parked page on the https: version of the URL, and your wordpress site on the http: side

To be honest, I’m not sure how you did that. I’d chat with support, you have something configured strangely.


#5

It looks like there is something misconfigured: when I request http://www.farawayfamily.com/ I get your WordPress site but requesting https://www.farawayfamily.com/ gives me the parked domain page.

Did you enable Secure Hosting on that domain? Check the docs: https://help.dreamhost.com/hc/en-us/articles/215089118-Adding-an-SSL-certificate-overview


#6

thanks for responding. I talked to support and they say it will work in 15 min. Here’s the explanation in case anyone is interested:
“Possibly you had the domain parked prior while https was active and when switching to fully hosted http switched but https still stayed with the parked status. To fix it I removed and re-added https to the domain, so https used the correct hosting setting.”


#7

Thanks for sharing the solution here! Closing the thread.


#9