Change max upload size problem


Just now, i followed the tutorial of the change max upload size from
but i have one problem, while i use custom ftp command, chmod +x php_update,
the ftp client software come out "The command is not understood by the server.
i need to change the max upload size to i liked.


I think you will have more success logging into the shell via ssh to to manipulate these files than using your ftp client.



I just see SSH2, dont have SSH


may i know how to login into shell via ssh?
i’m new to linux


I was just referring to ssh in general terms - DH is compatible with ssh2 and you should be able to log into the shell with ssh2 as well :wink: .



i use the SSH2, but it’s list out this problem:
Can’t connect to SFTP21 error = #7.

#7 should give you additional information on using ssh/ssh2 on Dreamhost. Make sure that your user has shell access enabled, as indicated in the wiki article. :slight_smile:



I’m sorry, I am not familiar with that error code. It may indicate that the protocol is not supported. Is the user you are logging in as a “shell” user? You can check by visiting the Control Panel–>Users screen and checking to make sure you user has the “shell” checkbox selected.

What platform/OS are you using to connect (MAC OSX, MAC OS9, Windows XP, linux, etc)? I have had excellent result using the free “puTTY” client.



i followed these steps you gave me the url address. but i can’t see the .ssh folder to cause i can’t upload the authorise keys into it, make any change for it. i using windows xp platform OS


If those steps are causing you trouble, you do not need to use passwordless login.

Using the puTTY program I suggested, just run the program and connect to yourdomain.tld. It will prompt you for a user and password. Enter that interactively from the keyboard, and you should be able to connect. You can learn more about setting up passwordless login at a later time, when you have become more familiar with the *nix shell. :wink:



I also follow this page’s steps:
it list out the problem i asked just now.


If you followed the instructions on the page that you indicated in your last post, you will need to create the directory (folder) named .ssh in your “user” base directory on dreamhost (/home/yourusername/).

Again, you do not have to follow all of these steps to connect successfully; you can simply run putty from windows XP, enter for the “host name”, make sure port 22 is indicated, select the “SSH” radio button, and click “Open” at the bottom of the Putty initial screen.

PuTTY will then connect with the shell at Dreamhost and ask you for your username/password interactively. Enter those, and you should be connected.



i connected with the dreamhost using ssh2. while i connected, the command line closed automatically.


Do you mean the Windows command line?



my meaning is the putty connection to ftp ssh2 server


I see, Have you confirmed that the user name you are trying to use to connect is a “shell” user in the Dreamhost Control Panel?



Welcome to

Any malicious and/or unauthorized activity is strictly forbidden.
All activity may be logged by DreamHost Web Hosting.

This account allows only ftp connections.

what thats mean? password wrong? login name wrong?


Now it is making sense! You are connecting directly to the Dreamhost server rather than using your domain name, and the user you are using does not appear to be authorized shell access.

I have mentioned this several times; you must have your user enabled for shell access to connect via ssh (or telnet). If your user is an FTP only user, that will cause you connection to be refused if you try to connect via ssh, ssh2, or telnet even if you use the correct username and password for your (ftp) user.

Goto the Control Panel, Manage users screen and look at the user name you are using to login. Under the “TYPE” column, make sure that user is indicated as being a “shell” user, not an “ftp” user.

If the user is not indicated as being a “shell” user, click the “edit” link to the right of the “Disk Storage” column for the user name, and select the check box for “shell” in the next screen, and save the settings.

After a short wait, the user’s status will be changed and you will be able to login via ssh.



how to change max upload size using putty?
i’m new to putty?
while i connected, it connected to my ftp serveR?