CGI Scripts

I’ve tried to use both Moveable Type and Greymatter with DH and despite all of the tutorials and manuals I’ve read, I still end up with the same “error 500 internal server error”

Am I missing something? I’ve followed the instructions exactly, CHMODing the files exactly as I was told to. Everything appears to have been set up the way it supposed to, but I can’t seem to locate the source of this error 500…Has anyone had any luck installing Moveable type or Greymatter? If so, I would very much appreciate any insite you may have towards its installation process with DH.


A couple of questions.

  1. Do other scripts work properly? Find an example ‘test.cgi’ script and see if you can get it to work. Here’s a really simple one:


print “Content-type: text/html\n\n”;
print “\nHello!\n\n”;

chmod +x this, and see if you can get it to say “Hello!” in a browser.

  1. Make sure your permissions are right. I know you already did this, but do it again. :>

  2. (this kind of goes along with #1) Login to the panel and make sure that your domain has full CGI enabled (and set to run as the same user that owns the file).

  3. Are you editing the script on a Windows machine? The second leading cause of internal server errors (behind permissions problems) is when scripts have DOS carriage returns in them. You can use dos2unix to strip these, or simply open the file in pico and save it (^O).

  4. Does the script execute from the command line (./script)?

  5. Check your logs and see what kind of error you’re getting.

Just in case you missed this tutorial, you might want to give it a try. It includes my step-by-step instructions for installing Movable Type on a DreamHost virtual server.

I have gotten feedback that it was very helpful from a surprisingly large number of people. In fact it is probably the most popular link on my site, next to the story I wrote about the incinerator toilet at my cabin in Tahoe and the page linking to the Bush and Blair lip synching video.

If the instructions don’t work for you, you are welcome to email me for more help at robert AT wombatnation DOT com.