Cgi-bin/dispatch.cgi/public/index.php


#1

For some reason my site redirects to this directoy. I have no htaccess files anymore, so I am unsure of whats causing the redirect.

I had installed zend framework and earlier everything was working fine. I checked later and it no longer worked, broken redirect. So I removed all my htaccess and now it does this.

Any ideas?


#2

Without the URL, it’s hard to say. Your browser may have cached something. There really may still be a .htaccess file. What index file do you have in your site’s root directory?


#3

No index file. It should, in theory, just show the directory.


#4

Ok, so I deleted the domain from web panel an then I also deleted the folder from the ftp. Then I re-added the domain and…

And…well…

it still redirects.

Any ideas?

http://www.amy-and-tony.com/


#5

Make sure to check the directories “up tree” to see if you have a .htaccess file there. I have seen this fairly often where an .htaccess file ends up in the user FTP directory.


#6

other domains for the account still work fine. And the root shows no htaccess…good idea though, wish it were the case :frowning:


#7

I’m getting a plain page with just the text of “Test.” It looks like you got it working.


#8

Well, when I removed the domain from the host then added it, I think it fixed the issue, it just took a while for it to propogate. Still not sure what “caused” it in the first place. I will try to install zend framework again and see if I run into the same issue.[hr]
Sure enough, executing the following commands in shell caused the same issue…

alias zf=/home/ajlisowski/ZEND_framework/bin/zf.sh

source .bash_profile

zf create project amy-and-tony.com

interesting…


#9

Now I’m getting the bad_http_conf error, which may be caused by this:
http://wiki.dreamhost.com/Bad_httpd_conf


#10

Well, I totally F’d up now…

this is a disaster.

I backed up and deleted everything from my root to try and figure out what was causing it.

Now, I swear I backed it up first but I have no idea where it is…any way to get the bash file and everything else in my root directory back?[hr]

Phew, I searched and found my backup…no worries.

Ok…now I have executed all the zf commands and have a project at amy-and-tony.com

i do not have an .htaccess file setup so you just see the root, so far so good.[hr]
Ok, as of right now…

I have a working default zend framework installed with an htaccess successfully set up.

www.amy-and-tony.com

sucessfully shows the /public directory which shows the default zend framework screen.

It appears everything is good. However, I was at this stage yesterday around this time and then without touching anything began getting that crazy redirect like 4 hours later when I went to actually start working.

I am taking another break now…hopefully in a few hours im still good to go.

Thanks for the help / just letting me talk myself through this and not feel alone :slight_smile: