CatchAlls as described in Newsletter


#1

Hi All,
I was just flicking through the newsletter when i found the section regarding the new catch-all feature - basically they say:-

[quote]Starting right now, all your email addresses have a sneaky new feature:

Built-in catchalls!

How does it work? It’s easy! For every email address we host you can add
a + sign and then ANYTHING before the @, and it’ll go to the same place.

So, if you have an email address like say:

josh@ilovemoneyandbunnies.com

The following addresses now all go to the same place:

josh+ferrets@ilovemoneyandbunnies.com
josh+jones@ilovemoneyandbunnies.com
josh+dreamhost_spams_dont_they@ilovemoneyandbunnies.com
[/quote]
But… It dosent seem to work on my domain - i send a mail to me+test@mydomain.co.uk and i get an undeliverable message back.

Any Ideas?


#2

I just tried it with one of my .com domains and it worked as advertised. Strange that it didn’t work for you.

–rlparker


#3

Certainly seems to be working here as well. Check that your me@mydomain.co.uk does actually exist (i.e. not a newly created email address) and already accepts mail and that me+test@mydomain.co.uk isn’t in your delete list.

Make sure you are using the plus sign normally over the equals symbol.

Check that your email client or isp are not stripping out the ‘+’ to “help” you.


Norm

Opinions are my own views, not DreamHosts’.
I am NOT a DreamHost employee OK!! :@

You act on my advice at your own risk!


#4

Doesn’t work for me either. Gets a “user unknown” message. :frowning:


#5

Have you tried a test from the DreamHost ControlPanel Webmail to see if that works?


Norm

Opinions are my own views, not DreamHosts’.
I am NOT a DreamHost employee OK!! :@

You act on my advice at your own risk!


#6

It works only when I send from a Dreamhost mail account, not from an external email system like Google Mail or Comcast.

External email systems give me a “recipient address rejected: user unknown” error.


#7

Whilst plus tagging ( address@example.com) is permitted under RFC notes there are still some companies whose servers will strip out the plus sign. (no I do not know which companies just that there may be some).

Try various clients just to make sure it is working okay. You could also try "me test"@example.com through Comcast to see if that works.

I have just tried Google Mail with and without quotes and the mail is rejected. So it looks like Google Mail causes a problem.

Later…

Oh, plus tagging does work from Google Mail. I just did a dyslexic on my email address :frowning:


Norm

Opinions are my own views, not DreamHosts’.
I am NOT a DreamHost employee OK!! :@

You act on my advice at your own risk!


#8

Tagged addresses don’t work from Google Mail to my domain.

“vince+save”@vkimball.com

Technical details of permanent failure:
PERM_FAILURE: SMTP Error (state 9): 550 vince+save@vkimball.com: Recipient address rejected: User unknown.

If I use quotes or not, same message.

Also with Comcast:

“vince+save”@vkimball.com

Technical details of permanent failure:
PERM_FAILURE: SMTP Error (state 9): 550 vince+save@vkimball.com: Recipient address rejected: User unknown.

With or without quotes, same error.

Maybe some of Dreamhost’s email servers haven’t been updated yet?


#9

That was the same error I had when I made my typo. Make sure that you can send email to vince@vkimball.com okay from Google Mail first.


Norm

Opinions are my own views, not DreamHosts’.
I am NOT a DreamHost employee OK!! :@

You act on my advice at your own risk!


#10

vince@vkimball.com works from Google Mail, but vince+save@vkimball.com doesn’t.


#11

Messages sent from my webmail get this reply, I get a similar reply from yahoo’s mail servers.

This is the Postfix program at host webmail2.sd.dreamhost.com.

I’m sorry to have to inform you that the message returned
below could not be delivered to one or more destinations.

For further assistance, please send mail to

If you do so, please include this problem report. You can
delete your own text from the message returned below.

The Postfix program

: Recipient address rejected: User unknown in virtual
alias table


#12

I’ve got the same results: not working from gmail

Delivery to the following recipient failed permanently:

gordaen+notspam@quittryingtograbmyemailaddressyouspambots.com

Technical details of permanent failure:
PERM_FAILURE: SMTP Error (state 9): 550 gordaen+notspam@seriouslyjuststop.com: Recipient address rejected: User unknown.

I sent one from my main webmail account to the SAME account but with “+wtf” after the username… The message hasn’t been delivered or returned.

Check out Gordaen’s Knowledge, the blog, and the MR2 page.


#13

This wasn’t working for my primary address either so I did a little experimenting and think I’ve narrowed down the source of the problem to the junk filter.

Plus-addressing works with addresses at domains not using the filter, but these messages consistently bounce when sent to addresses at filtered domains. Only one person in this thread has mentioned his domain name, but I see that that one is filtered as well.

Anyone else see similar results on filtered and non-filtered domains?


If you want useful replies, ask smart questions.


#14

My original test was done on a non-filtered domain, and it worked fine. I just went back and sent to a “filtered” domain, and received a bounce. I think you have narrowed it down!

Additional: I also tried it with multiple sending domains, including gmail, with the same results - the mail is delivered to a non-filtered domain, and bounced by a “filtered” domain.

–rlparker


#15

[quote]This is the Postfix program at host webmail3.sd.dreamhost.com.

I’m sorry to have to inform you that the message returned
below could not be delivered to one or more destinations.

For further assistance, please send mail to

If you do so, please include this problem report. You can
delete your own text from the message returned below.

The Postfix program

gordaen+wtf@blah.com: host fltr-in3.mail.dreamhost.com[66.33.206.232]
said: 550 gordaen+wtf@blah.com: Recipient address rejected: User
unknown.
[/quote]
Yeah, mine is filtered and the above is an attempt to send from gordaen@ to gordaen+wtf@ (same account) which failed.

Check out Gordaen’s Knowledge, the blog, and the MR2 page.


#16

Worked for me. I’m not using DH’s spam filtering; maybe that’s the difference.


#17

Word of advice… unless you want to be deluged with spam, [color=#CC0000]DO NOT post your actual email address that you use on any forum.[/color]

It will get harvested.

Even trying to “mung” it by going [color=#00CC00]myname[at]REMOVETHISPART example (dot) com[/color], etc., will still be picked up by a powerful spam harvester.

Better solutions are here, here, here, here, here, here, and here.


#18

Sorry everyone! As you have figured out some of our email servers had not yet been updated, notably the junkmail servers. It should now work for all addresses with or without the junkmail filter enabled.

  • Dallas
  • DreamHost Head Honcho/Founder

#19

Confirmed, I was using a filtered domain, yesterday it didn’t work, today it did - thanks for clearing this up and all your help guys.


#20

Very true of course.

I just wonder about plus tagging now. As useful as it is it seems to have introduced some new dangers and there should be a way to turn it off (unless there is) per email address.

Having persevered for some months to remove the catch-all feature out of my domains it has virtually been restored again now to every domain email address. All I can do is block each name as it gets spammed unless I want to permanently remove the email address that is before the plus tag part.

If it were selectable when an email address was created I could then also create a throwaway alias to use with my plus tagging feature. So that if and when a spammer decided to just add a serially increasing number as the tag I could remove the alias.

I am not trying to be negative here by the way as I think DreamHost are serving their customers very well with all the new features.

But I have some small concerns. (Yes I know, that is an old joke!)


Norm

Opinions are my own views, not DreamHosts’.
I am NOT a DreamHost employee OK!! :@

You act on my advice at your own risk!