Catch-all mail for added domain not working

My main domain of “” has a catch-all email forwarder that works just fine.

Recently, I added another domain “” under my account. For this domain I set the mail-> addresses entry to forward mail addressed to ‘*’ in domain “” to a specific mailbox - e.g. "".

After a day or two I tried sending emails to various addresses and none of them ever arrived. I then ditched the catch-all in and instead setup a specific mail name in (with the same destination mail address) and that forwarding works just fine.

Any idea why catch-all on an additional domain would not work?


Did the catchall point to ""? It should point to a physical mailbox (though if "" was an existing address pointing to an actual mailbox, that should have worked too).

There’s no reason why an additional domain would function differently than another domain, though (unless you set its mail service to mirror the other domain specifically).

OK, I figured it out.

I was trying to point to an email address on my existing “” that wasn’t really a mailbox - it was an alias.

I got things to work by only directing things to a “real” mailbox.


Setup “A” bad: -forward-> -forward->
Emails sent to "" never get to ""

Setup “B” good: -forward->
Emails sent to "" now arrive fine at "