Capistrano setup problems, please help=(


#1

Hi all,

I’ve been bashing my head over this the last day or so. I am using the DH wiki to setup capistrano so I can deploy my app. Here’s what I have.

  1. SVN repo setup at www.myserver.com/development with the latest revisions commited.
  2. My domain www.myserver.com setup with FastCGI and current/public set as the “base” directory (I also deleted these folders manually so that the symlinks would be setup).
  3. production database setup.

The problem is when I try to run “cap setup” it show some messages that appear like its creating the releases and shared directories, but then it prompts me for a password and then fails the authentication after I enter one. I have tried both my DH password and the one for SVN.

The wiki states that I should try to ssh and create a temp directory then export from SVN to that temp directory so that it will be authenticated on future tries. I tried that and it still fails on cap setup. Please help! I’m pretty sure it’s not my deploy.rb file because DH isn’t even letting it have access. Here’s my errors (hosts and usernames altered):

[quote]cap setup
[/quote]

  • executing task setup
  • executing "umask 02 &&\n mkdir -p /home/myusername/mydomain /home/myusername/mydomain/releases /home/myusername/mydomain/shared /home/myusername/mydomain/shared/system &&\n mkdir -p /home/myusername/mydomain/sh
    ared/log &&\n mkdir -p /home/myusername/mydomain/shared/pids"
    servers: [“myusername/mydomain”]
    Password: ***********

authentication failed for `Administrator’


#2

I have yet to get Capistrano running; the documentation I’ve seen just hasn’t made sense. But I’ve found I didn’t really need it.

Currently, when I have changes to deploy, I ssh into my DH server and run just two commands:

#svn update
#rake db:migrate

So far that’s as fancy as I’ve needed. At some point when things get more complicated, or when I feel the need to pound my head against a wall, I’ll make another go at Capistrano. :wink:

Now, if you do get it going, please feel free to update the wiki!

Cheers.

rodney