Capistrano not creating pid files for FastCGI

apps

#1

I’ve got Capistrano working perfectly except for one thing: On each deploy, Capistrano fails to restart the FastCGI process. The output shows:

Couldn't find any pid file in '/home/vocaro/researchpla.net/current/tmp/pids' matching 'dispatch.[0-9]*.pid' (also looked for processes matching "/home/vocaro/researchpla.net/current/public/dispatch.fcgi")
When I look in the current/tmp/pids/ directory on the production server, I never see any files.

I know there are workarounds, such as modifying the restart task to kill any dispatch.fgci process it finds, but I’d still like to know why the pid files aren’t being created.

I’ve read the wiki article but can’t find any mention of this problem. Any suggestions?


#2

I see that the Nuby on Rails site offers a replacement for the restart task:

desc "Restart the FCGI processes on the app server as a regular user." task :restart, :roles => :app do run "#{current_path}/script/process/reaper --dispatcher=dispatch.fcgi" end
Is that the best solution?


#3

That looks correct.

I have something similar in my deploy.rb file.


#4

Im having the same problem
I tried the nuby on rails code but Im using passenger
and still having the same error

here is my updatred thread http://discussion.dreamhost.com/thread-129537.html?highlight=capistrano