Can't use "nice" ?!


#1

I wanted to untar a large file, and I said “Let’s use ‘nice’ just not to use too many resources” but I got a reply on the terminal saying I can’t change priority of my processes…

Why?!!


#2

You should be able to. Contact support, Panel > Contact support.

–Matttail
art.googlies.net - personal website


#3

Yeah, I’ve used nice before.

Free unique IP and $67 off with promo code [color=#CC0000]FLENSFREEIP67[/color] or use [color=#CC0000]FLENS97[/color] for $97 off. Click here for more options


#4

It’s unlikely I know, but just in case, what command did you give, precisely?

[color=#00CC00]ANONYMOUS0=>Max Discount[/color] [color=#6600CC]ANONYMOUS2=>Max - $1.[/color] Being mean doesn’t make you look smarter than him. And bigoted remarks are not appreciated on this forum.


#5

I typed:

%nice 19 tar xvjpf file.tbz file


#6

I like to be considerate too. You can’t use nice because of something that has to do with launching the process. “renice” is the key. Just do a “ps” and find out the number of your bash process. Then renice the shell.

i.e.: “renice +15 2772” assuming that ps shows 2772 for your shell process.


#7

Thanks!


#8

or you could just type:

nice -19 tar xvjpf file.tbz fileor

Free unique IP and $67 off with promo code [color=#CC0000]FLENSFREEIP67[/color] or use [color=#CC0000]FLENS97[/color] for $97 off. Click here for more options


#9

Getting the minus signs right can be difficult. :wink:

[color=#00CC00]ANONYMOUS0=>Max Discount[/color] [color=#6600CC]ANONYMOUS2=>Max - $1.[/color] Being mean doesn’t make you look smarter than him. And bigoted remarks are not appreciated on this forum.