Can't Upload


#1

Cannot figure out why ftp uploads are so flakey from my home computer.

From my work computer: …no problem

From my home: it will work fine for awhile then it will go into a “funk” and won’t upload. Download is fine. Listing the contents of a directory is fine. Deleting is fine. But uploading will hang with an hourglass and the file size on the remote is zero.

Can successfully transfer files <1KB!

Cannot store files >1kb. The log is the same as for smaller files but hangs after STOR. From log:
COMMAND:> STOR
STATUS:> Connecting FTP data socket …
STATUS:> Passive connection established.
STATUS:> Data socket info: (local)… - (peer)…
150 Opening ASCII mode data connection for
Then, after a period of time…
ERROR:> Timeout (60000 ms) occurred on receiving server response.

Same behavior with Keep Alive on or off.

On both computers: WinXPPro, SBC DSL, CuteFTP 7. Happens with Dreamhost and Yahoo webhosting.

I first saw the problem at home when using free SmartFTP and blamed it on the program. But, same problem with Filezilla and CuteFTP Home 7. I use CuteFTP Pro at work.

Using default settings for CuteFTP:

  • protocol: FTP, port 21
  • server type: autodetect
  • transfer method: auto detect

Any suggestions?

Thanks


#2

Other users have reported similar. DH have said “Large files and dial-up connections just don’t really work I’m afraid!”.

I found failure with one connectivity provider and FTP client, and success with a different provider and client.


#3

I can’t blame DH since it happens with Yahoo Webhosting, too. And, I’m on DSL (asynch). At least with Yahoo, they had a web-based file upload utility. It would be awful to use regularly but was useful in a pinch.


#4

I can upload from another computer in the house (sharing the same router, DSL modem). So it’s something on my computer.

Does this make sense to anyone?


#5

Globalscape (CuteFTP) got back to me suggesting I change ‘Data Connection Type’ to POST. That worked. Went back to default setting and now it works. ??? Maybe WinXP has some setting that needed resetting and this did it.

Globalscape answered a question promptly. Wow! I will forever be loyal.


#6

i still have similar problems… some days it works, some days it doesn’t… all this happening since they started upgrading :frowning: And no solution from support… they say its my connection, but i have tried different computers, and different connections, and problem remains, but there was no prob before the upgrade :frowning:


#7

I’m not having problems uploading…I mean files are uploading just fine. It’s just that when I try to view my directories, those changes are not reflected. Any new file I try to upload doesn’t show up.

I tried FTP uploading a directory and it stopped before all files were done. I tried again, and now all the files are listed in the FTP client, but do not show up at finnesey.org/spiders/

Also, I can FTP download the files I transferred, but I cannot download them via HTTP. So it’s not just the directory index that’s not getting updated.