Can't Upload File


#1

I install a Forum,and when i Post New Thread,i just can not upload any file.I have tried many Forums of diffent versions,but it still does not work…attechment is not available,the tip is:"Upload of file failed."what is the problem??

here is my Forum:
Http://www.mamarat.com/bbs/index.php

user:test
pass:test


#2

#1 the files must be under 7mb in order to upload.
#2 Check the config in VB and check the permissions on the upload script/directory.

digitalrundown.com
Promo Code: WJD97 - $97.00 off any new DreamHost plan (except month-month payments).


#3

#1 I m sure that file under 10kb
#the config and permissions on the upload script/diectory is ok 2…

will you please help me check the problem?:)I m now helpless…mmmm,I beg u…

Administrator:admin
pass:123456

Thanks


#4

I’ll take a look but I would remove the username and password from the forums. You don’t want everyone to be able to see that.

Edit: Took a look, not path is set.

/path/to/your/attachment/directory

should be:

/home/mamarat.com/attachment/directory

digitalrundown.com
Promo Code: WJD97 - $97.00 off any new DreamHost plan (except month-month payments).


#5

Upload of file failed. still not work…

u try toPost New Thread n upload a file.


#6

any one can solve my problem?


#7

I just tested the upload and it failed. My guess is you don’t have the folder where the images are uploaded to set to the correct permissions.
You will find an article about chmod in the DH wiki.
Silk


#8

I am having this same issue at the moment. I don’t know if it’s related to the DNS general flakiness or not. I’m using a very simple piece of code (essentially copy($pic_name, $dest) to upload pictures to my site.

I’m a web developer and I’m currently using this exact piece of code (successfully) on at least 2 other sites.

Support has said they don’t troubleshoot third party software (since when does one line of simple code constitute “third party”?) and recommended I try here for a solution. I’m trying to launch a client web site, so as much as I don’t know if it will help, I’m posting.

I did research the wiki and the Knowledge Base, and I’ve had an issue before where even if the file is in the right place, open_basedir will act flaky and not allow you to upload the file. I’m running PHP 4.0 as a CGI.

Any advice on this would be welcome, I’m getting very frustrated at this point.