Can't update plugins or theme


#1

Since DreamHost updated WordPress to 4.5.3, I have been unable to update plugins and the uDesign theme. Each time I try and update, I get this error:

An error occurred while updating UpdraftPlus - Backup/Restore: Download failed. Failed to write request to temporary file.

Here’s what I’ve done so far without luck:

  1. I’ve double check that all plugins I’m using are compatible
  2. I’ve cleared browser and DNS cache
  3. I’ve disabled all the plugins and tried to update them one at a time with the other plugin disabled
  4. I have tried to find the temporary file via ftp with no luck.

At this point, I have ran out of ideas. It seems this problem started with the mail server started having issues.

I do manage other sites and I use the same plugins and I’m able to update without an issue.

Can you help


#2

That sounds like a file/directory permissions issue. Support should be able to fix it for you, or you can FTP in and check permissions on wp-content and its enclosed folders such as “themes” and “plugins”.


#3

I just checked and all the folder’s permission is 755


#4

Did you ever find out what the problem was? I’ve been dealing with a similar problem for a long time and have had no luck with Dreamhost support.


#5

No. I decided to change themes because they were not responsive. I have found other themes that are 100% better on https://themeforest.net/. Personally, if I was you, I would switch themes. This theme, Knox, is my new favorite theme. https://themeforest.net/item/knox-multibusiness-modern-wordpress-theme/20358904


#6

On my sites on Dreamhost, I use the Genesis Framework which is excellent. I’m a web designer and I have clients using Genesis hosted elsewhere and have never had a problem updating plugins.


#7

That’s the correct behavior :slight_smile: This sort of issues should be identified properly and solved. I’m not familiar with any of the frameworks you mentioned but file permissions should not get messed up.

Can you please add more details to the thread? Is this issue always present? If you have already investigated this with Support, can you send me a private message with your webID?


#8

I get regular notifications about my DreamPress updates, but when I view my WP dashboard, there are always updates available… as if the automated updates never happened. When I try to run them manually, I’m prompted for my host information, but my credentials do not work. However, these same credentials work when I log into the shell. When I try to run updates from wp-cli, they fail with a message that the latest update is already installed. Back in my dashboard, it shows that all of those same plugins have now been deactivated and removed… which breaks my site. I also thought this was a permissions issue, but everything is set to 755. I have an open support ticket, but have not heard back yet. Meanwhile, my site is nothing more than a bunch of unrendered shortcodes…


#9

When I was reading your message, the first question that popped to mind is “Are you looking at the right dashboard?” What you describe is so strange that the only explanation I can think of is that you get the notifications for a different site, that there are wires crossed somewhere… Without more details I can’t think of anything more.

Hopefully my colleagues will respond soon. Please share back what the solution is once you get it. Or provide more details here… Logs would be good to look at, access and error log.


#10

Maybe not, and here’s why I’m confused about that…

I had a regular WP install running as my production site with a domain name like example.org.
Realizing the benefits of DreamPress, I started a staging/development instance with Dreampress at a subdomain of dev.example.org.
When it was time to deploy, all I did was log into the shell, rename example .org to example .org .old, and renamed dev .example .org to example .org. The DNS and databases point correctly, so the site works fine.

So, are the DreamPress automatic updates domain-specific? Or are they linked to some other unique identifier behind the scenes? Did I break the updates by renaming the installation folder?


#11

Every WordPress site (all of them, not just DreamPress) has its base URL set in its configuration. Have you updated that setting after changing from dev to production domain?


#12

Yes. I think that’s the only thing I had to change in WP when migrating from the dev domain.

Tech Support was able to get back to me with this response:

This error that you are receiving is generally caused when your WordPress
doesn’t have the correct ownership assigned to the site files. I went
ahead and did a update on all of your site files as well as a permission
update to make sure everything was set correctly.

Sure enough, the updates now work correctly, both in the Dashbord and from WP-CLI. (I had to re-download my plugins, but fortunately I had a list of the missing ones.)

So, it appears that by renaming my dev subdomain folder to the production domain, I didn’t break the site (or the automatic DreamPress updates), but I somehow managed to dissociate my username from my own WP installation.

After some further reading, it seems the proper way to deploy a DreamPress installation from a Staging environment to a Production environment is to:

  1. stage your development version at a DreamPress temporary domain, and then
  2. change the DreamPress temporary domain to your live site by managing the domain through the Dreamhost Panel > DreamPress > Dashboard.