Can't Send emails through Entourage X for Mac

Just set up my domain name and bought hosting with Dreamhost. I have been trying, unsuccessfully, to send emails through Entourage X for mac. Somehow, I can receive emails, I just can’t send any.

What’ I’ve tried

-Setting up a POP account.
-Setting up an IMAP account.
-Overriding the SMTP default of 25 and setting it to 587.
-Selecting the “SMTP requires Authentication” option.
-Un-Selecting the “SMTP requires Authentication” option.
-Clicking on “SMTP requires secure connection (SSL)”
-Un-Clicking “SMTP requires secure connection (SSL)”

This is getting incredibly frustrating. Any advice would be greatly appreciated.

I don’t use Entourage, and haven’t had problems with

What happens when you try to send? As an experiment, go to Terminal and type in:
telnet mail.YOURDOMAIN.COM 25
(or 587 if 25 fails)

It should at least connect to a DreamHost mailserver. Beyond that, it’s probably an authentication issue. Password?

I’d start with the basics. POP and IMAP make no difference, but make sure you have SMTP Auth turned on, and SSL turned off.


Thanks Scott,

You are right on target. I was able to get my email up and running with help from dreamhost support!

I posted a screen shot of my advanced sending options on my website and here is what dreamhost support wrote:

“I’d be happy to help with this! So I looked at the screenshot and it
appears you have SMTP SSL on, which is only supported on port 465. SMTP
Auth and TLS are supported on ports 25 and 587, however SMTP SSL must
have an exclusive port because it’s an SSL connection by default. In
order to get this to work, either override the smtp port to 465 or turn
off SMTP SSL and use 25 or 587. If you have any further questions about
this, please let me know!”

What I did:

I turned off the SMTP SSL option and then overrode the default port to 587.

Email is humming along like charm now!!

There is more on this on the Beginner’s forum under a thread by the same name: