Can't see .htacess using FTP client


#1

Hi,

I can’t edit my .htacess file in my domain folder using FTP client.
Anyone could help me with this? I’m using the first user and shell/telnet enabled.

I’m new with this stuff, btw, where’s php.ini located? I follow wiki instructions with “standard” settings and everything works fine, but i can’t see any php.ini in any folder.

Thanks in advance.


#2

Which FTP client are you using?

php.ini only applies if you’ve compiled and installed your own PHP.

-Scott


#3

Thank you, sdayman

I’m using Cute FTP Pro 3.3

Yes, i compiled and installed my own PHP.
But i never did it before, only in localhost.
Maybe something wrong with this.


#4

I can’t see it either, until I select “Show hidden files” in my FTP application. Yours should have something similar. If not, get mine - Transmit. Very good.

Any file that starts with a period is meant to be invisible.


#5

First, .htaccess files along with any other hidden files (starting with a period, “.”) do not show on most FTP programs. If you have an option in your FTP client to show it, it will be somewhere under its general settings as was said already. The best way to see/edit/remove it is under telnet.

In Windows, open up the command line under Start Menu > All Programs > Accessories > Command Prompt then type in the following when it comes up…

telnet yourdomain.com
(enter your username & hit enter)
(enter your password & hit enter)
cd /yourdomain.com
ls -a

You should then be able to see the .htaccess file in there. If you just want to edit the file on your computer and upload a new version, go ahead and do that like you do every other file. If you need to get rid of it, follow the above instructions and then type “rm .htaccess” and enter to remove it.

Hope that helps!


#6

Thanks all, for responses.

it’s not FTP client problem, i guess.
Because in another server i can see .htacess using the same FTP client.

It may be user permission?

Well, i still having troubles with php.ini too,
i compile and install it bymyself, but i can’t find php.ini.
(this is why i guess it could be user permission settings)


#7

Have you tried sing the DreamHost ftp option that is built into the control panel under ‘Users|Manage Users’ then click [login now]. You can then check what is supposed to be where hopefully.


Norm