Can't see .htaccess (FTP)?


I can’t see the .htaccess files, when using Total Commander as FTP client. How come, and how do I fix this? I didn’t have any problems with my previous host.


I know from using SSH that you must be sure that ‘Show hidden files’ or some similar option must be selected.

I found this info:
"Warning: Total Commander doesn’t show hidden/system files by default, but you can enable them in Configuration - Options - Display - Show Hidden/System files"


The option you’re mentioned is for local files (not FTP), and actually I’ve enabled this already.

I can’t find the option that enables me to see hidden files on FTP servers.


Why don’t you use SSH to log into your server ?

ls -la will show ALL files, even hidden ones.

pico .htaccess will enable you to edit it.


I’ve always used FTP, this is the easiest for me. I have a local version of my webpage. I change this, and upload changes using FTP.


You’ll just have to hunt arund for the settings to show hidden files on your server, or download another ftp client that can do it. the “.” infront of the file name makes it a hidden file, so you can’t see it.



Which command shows hidden files when using a FTP client?


I think “ls -a” would work from a FTP client if you can pass custom commands. I tried this from a command line ftp:
… sucesfully loged in…
ls -a
200 PORT command sucessfull
150 openning ASCII mode data connection for file list



After you create a ftp connection go to the NET menu and press : Ftp Show Hidden Files


Try using WinSCP (it’s free!)


When using filezilla : select from menu Server > Force showing hidden files.