Can't remove directories


#1

hey gang… i’m having trouble where i want to remove a directory off the web server, but my ftp programs says i can not, because the dir is not empty. but when i navigate into that dir, it appears empty (to me at leaste).

Is there a way i can remove these dirs myself and not have to bother DH support?


#2

You should be able to find a setting in your FTP program to allow you to delete full directories. Most of the time it’s off by default - which is why you can’t delete it. The reason you can’t delete it is probably becuase of a hidden file. You might also turn on showing hidden files so you can see and delete the remaining files.

Let me know if you need more specific help.

-Matttail


#3

I’m using ‘Fetch’ for mac OS X. I’ll have to investigate where those options might be set, because i dont see them right off the bat.


#4

When you report back you may want to mention what these folders are just in case they are root folders or folders in a different group where you do not have the right permissions to delete.


Norm


#5

SSH. Use the command: rm -r

Be VERY careful with rm -r. ALWAYS specify the directory name, NEVER use *. I’ve seen far too many accidents come from using rm -rf * in the wrong directory. lol


#6

Not to totally call out that this is posted under the ‘Noob’ catagory…

but what is SSH? I put the 'rm -r ’ into ‘FTP Commands’ in Fetch… but it didn’t recognize the command.

the directory in question is within an old install of PHPbb, and some other software i had running over on ‘G*Daddy’.


#7

See the wiki for a full definatino of SSH, but basically it’s a connection methoed to the ‘command prompt’ of your server at Dreamhost.

Can you turn on listing hidden files? That way you’d be should be able to delete what’s still in the folder. Perhaps the easiest way around your problem would be to log into FTP using http://webftp.dreamhost.com You can delete full directories from there.

-Matttail