Can't logon to incoming mail server (POP3)

I can’t logon to incoming mail server (POP3) for the life of me… I tried loging on w/ my email:, using as my incoming server…

i even tried that ugly m3829822 type logon… i tried SSL port 995 incoming…

I read this: smtp

i did everything user comments recommended… i can do everything except logging on my incoming mail server…

i know my isp doesn’t block port 25… because i can logon to other mail servers fine…

i’ve tried every conceivable combination… but it won’t logon to the incoming mail server…

i’ve even tried this:

i’ve made sure: MAKE SURE “Log on using Secure Password Authentication (SPA)” IS NOT CHECKED

i’ve made sure: Make sure “My server requires authentication” is checked!

i’ve set: “Set Incoming Mail (POP3) to 995”

I’ve tried: Outlook Express 6; I found the following works: “Tools>Accounts>Properties>Advanced>” Set Outgoing Mail (SMTP) to Port 587 and UNCHECK “requires SSL”. Set Incoming Mail (POP3) to 995 and CHECK “requires SSL” (when you CHECK the “requires SSL” box for Incoming Mail, it should automatically change to Port 995, but if not, you can set them separately). Hope this helps! All the rest is the same as described above by kbase/support team.

my mail server is: murdock

i have multiple domains w/ dreamhost w/in same account… and tried other email from other domains… and it still won’t work…

anyone having same prob? :frowning:

I can logon to my incoming mail server (POP3) only if i use my FTP account… but that doesn’t specify which mail account i want to download my mail messages… what does this mean?

Is your account name your mailbox number? m######? it isn’t the *'s *****, but your mailbox number.

also, when using “My server requires authentication” in your outgoing, make sure you select “use the same account info as incoming mail server.” <<or something like that.

have you tried going to

I am on murdock and have no problems.

hey thanks a lot… i tried the m****** method… and it works… thanks!!!

I have the same problem, but I was already using the correct mailbox number (m######). I actually have Outlook working on two other machines with the same account!!! Same password, mailbox number and everything, but it tells me that I can’t login to the incoming mail server because of incorrect password or id…but they are IDENTICAL to the ones I have on both of my other comptuers. I tested both the mailbox number and password a zillion times to see if I had just typed them wrong, but that is not the problem. Does anyone have any suggestions???

oops–I did just try setting the ports differently, and now it works (incoming to 995 with ssl and outgoing to 587 with no ssl)


please help!!

i’m soo confused! what is my mailbox number?!
m****** method…what is that?!

save me!


The posts you’re looking at are very old — they date back to a system that’s no longer used for naming mailboxes.