Can't login to FTP. My two sites cannot connect


#1

I’ve been trying to clean up after my two (WordPress) sites were hacked. One site was small and needed redone so I deleted it and started over.

This morning, I was cleaning up my other (larger) site, running an SSH command given me by DH Support to remove the malicious code from the infected files. It was taking forever in Cyberduck and had to stop it (on my laptop) to leave the office (could that be the problem?).

Now, I am not able to login to FTP (I’ve tried two different FTP clients). And now neither of my websites are loading (“cannot connect”). I can get into the Panel just fine, though, and don’t notice any problems there.

I’m waiting to hear back from support but I"m wondering if anyone has any ideas/suggestions while I wait. I’ll report on how this turns out.

Thanks for your help![hr]
Okay. It turns out my IP address was blocked for too many failed logins. Support confirmed my username/password so I’m not sure why I was having trouble logging in.

Anyway, now back to cleaning up my infected files.

Specifically, I’m trying to send a “2 line SSH command sequence” but I’m not sure how to do it. The command sequence is …

find . -name ".php" -type f |xargs sed -i 's#<?php /**/
eval(base64_decode("aWY.
?>##g’ 2>&1
find . -name “*.php” -type f | xargs sed -i ‘/./,$!d’ 2>&1

I’ve tried copying/pasting SSH command in both Cyberduck and Transmit. What am I not doing right?

I can do it manually, but I’d like to know how to do it with the commands! :slight_smile:


#2

Ah well. I just cleaned them up manually. Looks like I got it all.