Can't log into SSH


#1

I just signed up for a new DH account, with a subdomain since I haven’t figured out what domain I want yet. I want to set up a rails project, but I can’t get into SSH. I tried logging into myserver.dreamhost.com with my username and password, and tried username@username.dreamhosters.com, and tried both my FTP password and my control panel software, and can’t get in with any combination…when I try to log in, I do get a message saying something about the server is for FTP only…am I not able to SSH without a domain?


#2

Make sure the user you are trying to log in as is, in fact, a “shell enabled” user. What you are describing sounds very much like that user is set up as being an ftp only user.

Go to the Control Panel Manage Users screen, and confirm (by looking in the “type” column) that the user is currently set to an “ftp” user, then click the “edit” link for the user, and change that user’s settings to enable shell access for that user by clicking in the checkbox to enable shell/telnet access (and alternately select a shell from the “pull down” selection list) for that user.

You can also confirm your user/password combinations here.

Once the change has taken effect (you’ll know when you no longer see the “clock” icon next to that user when visiting the page) you should be “good to go”.

–rlparker


#3

If you didn’t already, you have to go to Users -> Manage Users, then click edit for your user and make sure the box is checked for allowing shell access.

You might have to wait a little while after enabling it before you can login.

Edit: That rlparker is a speedy one. :wink:


:stuck_out_tongue: Save up to $96 at Dreamhost with ALMOST97 promo code (I get $1).
Or save $97 with THEFULL97.


#4

well I feel dumb.

that did the trick, thanks :slight_smile: