Can't link to my adult site from main WARNING page

design

#1

Because my website has adult content, I wrote an HTML warning page with “enter” and “leave.” I saved the page as index.html in my FTP client (net2ftp) and could view the page on the Internet just fine.

HOWEVER, when I clicked on the “enter” link, which was a link to a page on my website, nothing happened. I tried to use other links. Still nothing.

I saved the file as index.php and had the same problem.

The page displays with no problems, but I cannot link to anywhere else on my site from that main index page. I can link to any outside website (when I click “leave” and go to google.com, for example), except my own.

I have no idea what I’m doing wrong. Any advice?


#2

If you publish the url, so we can see the code, we could probably answer your question (just to the entry page- that should not be NSFW?). :wink:

–rlparker


#3

Here is the html code. I want to put it as the index.html file for this url: www.mistressemilie.com. But I don’t have it posted now because it won’t let people click through to my site (see ENTER):

WARNING

This website contains images and text relating to bondage, sado-masochism, dominance and submission, fetish, and other ADULT themes. By clicking "Enter" you agree to this list:

1. You are at least 18 years old.

2. You will not show this content to anyone under 18.

3. You are accessing this site voluntarily and are willing to see this content.

4. You believe that BDSM, fetish, and related acts between consenting adults is neither offensive nor obscene.

5. You will not hold Mistress Emilie responsible if you do not meet the above requirements and choose to view this website anyway.

LEAVE

You don't agree to the above list.

Walk away, fast.

ENTER

You agree to the list.

On your knees and get in here!


#4

The problem appears to be that you are running WordPress (which uses index.php as the “main” page of your site) with an index.html file as a “gateway page”.

Where you have this:
ENTER

try this instead:

ENTER

and let me know how that worked for you. :wink:

–rlparker


#5

That seemed to do the trick for clicking into my site through “ENTER.”

But now ALL other links on my site click back to the WARNING page. Please tell me there’s a simpler solution than changing the address on EVERY link of my site.

???


#6

You are welcome, and I’m glad you got it sorted. :slight_smile:

–rlparker


#7

Wow, I got confused with the threading there, … I thought I saw that you had it working, and responded, but oh well… (I guess you edited the post after I responded by didn’t mark it as edited?)

Yea, I was afraid that you were going to have that problem when I looked at your index.html page, but. since you didn’t ask about it I figured you knew what would happen and had a strategy to deal with it. I didn’t want to presume to tell you what to do (I certainly didn’t want to get “punished” :wink: )

Rather than me try to explain all the ins and outs of it, I’ll point you to the “official” discussion of how to do what you want:

http://codex.wordpress.org/Creating_a_Static_Front_Page

This article discusses several ways/strategies for you to make a “splash” or “gateway” page - and that is really the way you should approach it.

If after following that guide, you have a specific question or a problem, post back and I’m sure the wizards here can get you set up. :slight_smile:

–rlparker


#8

Thanks again for such a quick reply! Actually, my knowledge of this stuff is pretty spotty. I just follow tutorials and advice and suggestions until I manage to get the effect I want. And usually nobody gets punished :wink:

I read through that tutorial and tried some of the suggestions. There seem to be quite a few ways to create that “static page” (from moving Wordpress to it’s own directory in my host’s server to simply dropping code into a php file in the themes folder). I followed the steps for two methods, and neither worked for me. Besides, the intro on the Create Static Page tutorial even says “The approach that follows on this page is no longer necessary with WordPress 2.1 or newer.” I’m using 2.3.1. I can make a static page, but that static page still includes the heading and sidebar. All I’m trying to do is create a simple WARNING page with enter and exit links.

I’m just completely stumped on why I can’t just point to my own website’s links through that index.html page. I guess it’s a lot more complicated than I thought. Any suggestions for reading about how this stuff works together? Thanks again.


#9

I understand that can all be confusing, and it probably doesn’t help that the tutorial has so many different ways to approach the subject. I guess they were thinking that “choice is good”, though it can add to confusion for those that may not understand what is happening.

Tha is indeed true, but that doesn’t mean you could not still use those methods; it only means that the later versions of WordPress have other “built-in” facilities for doing some of that so that you don’t have to use those kind of workarounds in most instances.

This is “the right track”, and shows you are getting “close”. If you can manage to replace that static page’s template with the code you have in your index.html file, you should have it nailed.

It might help you understand what is happening to point out that, actually, you did have it working fine (the index.,html loads, and it links correctly with your “exit” and “enter” links), except for the fact that once inside your WordPress site, all links “automagically” point to just “http://mistresssemilie.com/” instead of “http://mistressemilie.com/index.php”. Since there is no “filename” in that url, the apache webserver goes through it’s list of “known index pages” looking for something to load, and it finds your index.,html before it finds “index.php”, and it loads it. BTW, that is why your index.html loads when a visitor first comes to your page, so it’s a bit of a “catch-22” and is why you are having the problem.

It might seem that if you could just your domain set up to have apache to load the index.php by default (which is what it will do if you have no index.html) the problem would be solved, but then you would be right back where you started having no “entry” page.

All that aside, and moving more directly to your issue, since you are using WordPress 2.3.1, and do have the ability to set a pages as your home page, all you need to do it get rid of the headering/sidebars, and you can do that by using a custom template instead of one of the default one for the “Page” you want to use for your gateway (see http://codex.wordpress.org/Stepping_Into_Templates).

Essentially, what you need to do is create “template” file that does not include the header/siderbar, etc. and use that template with your “gateway” page.

–rlparker


#10

Once again, I have to thank you for such a thoughtful and clear explanation of how these things are working together. As you obviously know, it’s hard to get straight answers out there.

After some trial and error trying to figure out code for these templates, I threw up my hands and decided to just move Wordpress and my blog to a sub-directory. Where I failed in this before, was in not understanding which links to change in the WP dashboard “Options-General” section. Before, I had only changed one url (according to the tutorial, which wasn’t exactly addressing my particular concern), instead of both. The more I learned about how things are working together, a light bulb suddenly flashed and it seemed so simple: Now I’ve changed both urls to the subdirectory address and am using the index.php file in the root directory as my “splash” page.

As frustrating as it can be, I must admit I’ve learned some things on the way and that can never be considered time wasted.

Thanks again for your help!


#11

You are welcome. and I’m glad you finally got it working the way you want in spite of the frustrations… You method should work fine, and like you said, the extra learning never hurts.

You never know when something you picked up in this “adventure” will turn out ! to be useful in the future. Good luck with your site. :slight_smile:

–rlparker