Can't get url_fopen to work


#1

hi,

I installed my own version of php5 as described in the wiki. I then turned on the allow_url_fopen feature to On but I still get the error “Url file-access is not allowed” message.

I even created a cgi-bin folder in my root site folder but I’m still having this problem.

any help would be much appreciated. thanks


#2

Are you sure you’re running your new installation? A “version.php” file with the following may shed some light on this:

<?php echo phpinfo(); echo "\n"; ?>

The point your browser to http://www.yourdomain.com/version.php
About the second page down will tell you if allow_url_fopen is on or off.

-Scott


#3

It is off.

I followed the instructions in the wiki carefully I dont understand why this is not working.


#4

this is weird, I even tried increasing the maximum execution time to 100 seconds and I still get the following error:

Fatal error: Maximum execution time of 30 seconds exceeded in /home/.zarathustra/tincan30/digitalsalesdepot.com/curltest.php on line 34

I don’t think the scripts are using my custom installed version of PHP. what should I do?


#5

You should rewrite your script to use cURL instead.

si-blog
Max discount on any plan with promocode SCJESSEYTOTAL


#6

curl works but it seems to take much longer than accessing the image through URLs. I’ll stick with curl. thanks