Can't get stats on Drupal Website


#1

I have Gallery and Drupal set up on my website, and when I go to the /stats/ directory I get the drupal “page not found” message.

Here’s my .htaccess file:

Apache/PHP/Drupal settings:

Protect files and directories from prying eyes.

<Files ~ “(.(inc|module|pl|sh|sql|theme|engine|xtmpl)|Entries|Repositories|Root|scripts|updates)$”>
Order deny,allow
Deny from all

Set some options.

Options -Indexes
Options +FollowSymLinks

Customized error messages.

ErrorDocument 404 /index.php

Set the default handler.

DirectoryIndex index.php

Override PHP settings. More exist in sites/default/settings.php, but

the following cannot be changed at runtime. The first IfModule is

for Apache 1.3, the second for Apache 2.

php_value magic_quotes_gpc 0 php_value register_globals 0 php_value session.auto_start 0 php_value magic_quotes_gpc 0 php_value register_globals 0 php_value session.auto_start 0

Reduce the time dynamically generated pages are cache-able.

ExpiresByType text/html A1

Various rewrite rules.

RewriteEngine on

Modify the RewriteBase if you are using Drupal in a subdirectory and

the rewrite rules are not working properly.

#RewriteBase /drupal

Rewrite old-style URLs of the form ‘node.php?id=x’.

#RewriteCond %{REQUEST_FILENAME} !-f
#RewriteCond %{REQUEST_FILENAME} !-d
#RewriteCond %{QUERY_STRING} ^id=([^&]+)$
#RewriteRule node.php index.php?q=node/view/%1 [L]

Rewrite old-style URLs of the form ‘module.php?mod=x’.

#RewriteCond %{REQUEST_FILENAME} !-f
#RewriteCond %{REQUEST_FILENAME} !-d
#RewriteCond %{QUERY_STRING} ^mod=([^&]+)$
#RewriteRule module.php index.php?q=%1 [L]

Rewrite current-style URLs of the form ‘index.php?q=x’.

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^(.*)$ index.php?q=$1 [L,QSA]

Rewrite to allow access to DreamHost stats

RewriteCond %{REQUEST_URI} ^/stats/(.)$ [OR] RewriteCond %{REQUEST_URI} ^/failed_auth.html$ RewriteRule ^.$ - [L]

$Id: .htaccess,v 1.66 2005/03/20 19:15:00 dries Exp $

Is there something that is write here - I thought the final section of that .htaccess file would cover the stats directory?

Thanks so much for your help!


#2

This worked well for my drupal sites. I´ve removed comments except those who tags DH stats.
Take a look

Apache/PHP/Drupal settings:

<FilesMatch “(.(engine|inc|install|module|sh|.sql|theme|tpl(.php)?|xtmpl)|code-style.pl|Entries.|Repository|Root)$”>
Order deny,allow
Deny from all

Options -Indexes
Options +FollowSymLinks

ErrorDocument 404 /index.php

DirectoryIndex index.php

php_value magic_quotes_gpc 0 php_value register_globals 0 php_value session.auto_start 0 php_value magic_quotes_gpc 0 php_value register_globals 0 php_value session.auto_start 0 php_value magic_quotes_gpc 0 php_value register_globals 0 php_value session.auto_start 0 ExpiresByType text/html A1 RewriteEngine on RewriteCond %{REQUEST_FILENAME} !-f RewriteCond %{REQUEST_FILENAME} !-d ### DH stats access RewriteCond %{REQUEST_URI} !^/stats/(.*)$ RewriteCond %{REQUEST_URI} !^/failed_auth.html$ ### DH stats access end RewriteRule ^(.*)$ index.php?q=$1 [L,QSA]