Can't Get Mojo Mail Backup to Work

software development

#1

I’m attempting to use mojo_backup.pl included with Mojo Mail 2.7.1. I try running it from a command line and I get nothing – no errors, no messages, no backup, nothing.

Permissions appear to be set correctly. The backup directory exists. Paths to the proper directories are set correctly.

The only thing that’s questionable, although I believe I have it right, is the following:

[quote]=item Where are your perl Libraries?

Since this script is supposed to be run via a cron job, (although it
will work fine using from the command line) you usually have to type
the entire path to your Perl Libraries.

example:

use lib ‘/usr/local/lib/perl5/site_perl/5.005/’;

=cut

use lib qw(
/usr/lib/perl5/5.005/i386-linux
/usr/lib/perl5/5.005
);[/quote]
I also have the following turned on, but still get nothing when I run the script:

[quote]=item Echo?

Finally, if you run this script interactively quite a bit, you may want
to have a copy of the report printed out in the terminal, so you can
figure out what’s going on, just set this variable to 1;

example:

my $echo_log = 0;

=back

=cut

my $echo_log = 1;[/quote]
Anybody have any ideas? Anyone have this set up and have it running correctly?

Thanks,
Wes