Can't get custom php 5.3 directive working


#1

Hi there,

I’m excited to see PHP5.3 at Dreamhost and how easy custom configuration should be.

I’m having a problem setting a custom php.ini directive with phprc as described in the above wiki page though. Here’s what I did

  1. Created the phprc file in my user folder:

mkdir /home/$myuser/.php
mkdir /home/$myuser/.php/5.3
touch /home/$myuser/.php/5.3/phprc

  1. Add a custom “max_execution_time” directive to the phprc file

max_execution_time = 300

  1. Save the file and try killing live php5.3 processes as described in the wiki

xxxx@xxxxxxxx:~$ killall php53.cgi
php53.cgi: no process killed

  1. Check the value of the max_execution_limit using the phpinfo() function:

max_execution_time 30 30

:frowning:

Am I doing something wrong?

Cheers,
David


#2

Obvious question: Are you certain you’re using PHP 5.3? The default is still 5.2.


#3

Yes, I switched to “PHP 5.3 FastCGI” for the domain on Tuesday (when I originally posted). I just went back and checked again to make sure it wasn’t just because the update hadn’t propagated yet, but I’m still experiencing the same problem.[hr]
Oops, my bad :frowning: It looks like my co-worker (who has since left the company) installed a custom php5.3 binary when it wasn’t available as an “official” option. Sorry for the bother.

David