Can't Ftp into My Server

dreamcompute

#1

Hi, I’m new to Dreamcompute and setup my first instance and installed Ubuntu 14.04 and Virtualmin and setup first virtual host with my domain name. I was able to setup ssh and was trying to upload wordpress for install but can’t connect to server via ftp at all. I get the following in filezilla:

Resolving address of mydomain.com
Status: Connecting to 173.xxx.xxx.xxx:21
Error: Connection timed out
Error: Could not connect to server

Any ideas as to why I cannot connect via ftp? I can’t find anything in the documentation and this server is installed just as is on another cloud host at rackspace. I temporairly disabled the firewall but still no success. The ftp user is setup in Virtualmin with ftp access.

Also when firewall running I can’t connect to phpmyadmin but can do so fine when it is disabled. I added port 3306 to the firewall and it had no effect.

Thanks…

Doug


#2

The first thing I’d recommend checking is your security group rules. Ensure you have a security group that allows incoming traffic on port 21 and that it’s assigned to that instance. You can think of security groups as an instance-level firewall. Those security group settings are here - https://dashboard.dreamcompute.com/project/access_and_security/


#3

Thanks for the reply. I added these two rules and associated them with the instance.

Ingress IPv6 TCP 21 default (couldn’t get this to be "::/0 (CIDR)"
Ingress IPv4 TCP 21 0.0.0.0/0 (CIDR)

This is the output now from Filezilla:


Status: Resolving address of mydomain.com
Status: Connecting to 173.xxx.xxx.xxx:21
Status: Connection attempt failed with “ECONNREFUSED - Connection refused by server”.
Error: Could not connect to server



#4

Is the FTP server installed and running on the instance?

https://help.ubuntu.com/14.04/serverguide/ftp-server.html


#5

Thanks for the help Justin with the support ticket, I decided to not use ftp and go with sftp. Accessing the server with filezilla and sftp is working just fine now…

Doug