Cant download site backup


#1

Hi, for safeties sake im trying to download a backup of my website hosted on dreamhost with no success.

My site is around 700 meg, it contains installations of mambo and ‘gallery’. When i try to zip it up using the web ftp service i get a ‘file is too big to move’ error. I try doing smaller directories, containing lots of files but <10 meg in size and i still get the same error. Any smaller than this and its going to be extremely laborious to do the backup.

Ive never ssh’d into my dreamhost account (My Crazy Domain Insane) and im pretty dissapointed that there isnt an easy backup service provided in the control panel like you have with cpanel.

Does anyone know an easy way to do a backup?

Cheers


#2

shell is the easiest way for manual archiving and backup.

If shell freaks you out a bit you can use an ftp client like WinSCP (it’s free!) that will run some basic shell commands for you straight out of the box (like zip/unzip directories). You can setup your own commands for those you use frequently too.

WinSCP Screenshots

  • Login to your (shell-enabled) account with WinSCP - Protocol: SFTP
  • Right-click any folder you’d like to compress/backup
  • Choose Custom Commands > Tar/Gzip
  • Give archive a name and hit Ok
  • Download your archive to local disk

Good Luck!


#3

WebFTP’s size limit is 7 megs. Use a regular FTP program and you’ll be fine.

-Scott


#4

Hi, thanks for advice, ive downloaded winscp and entered all my connection details according to http://wiki.dreamhost.com/SFTP
but it wont let me login, i just get ‘connection error:timed out’, Im not running any firewall.

Cheers


#5

Make sure your user has SSH access. Check the panel and edit your user, if need be.

-Scott


#6

Switch to standard ftp protocol (with the same user info) to test the connection.


#7

Switched to ftp and i got:
Timeout detected.
Connection failed.

I can login via ftp using other programs.

Any other ideas?


#8

Hi scott, my user is set to shell, which is meant to have ssh enabled.
I can login to ftp using other programs but not using winscp.

Cheers


#9

Check Control Panel > Security Center

Click Windows Firewall at lower right.

Click Exceptions TAB at top.

Look for Windows SFTP, FTP and SCP Client and ensure it’s checked.

If you don’t see it there at all, add it using the Add Program button.


#10

Thanks for your help, i got it to work by adding to comodo firewall which should have been disabled, but it decided it wanted to keep running, doh!