Can't connect to my site via browser




Can connect to new site via FTP, but nothing comes up in browser, evedn after I upload index.html, or any other web page. Only get “index of parent directory” listing … and exact page comes up 404.

I use Dreamweaver to create pages and upload.

I also added directory “public_html” and copied files to this directory, cuz it wasn’t there, like I’ved seen with most other sites I’ved done.

No DH phone number to call. Anyone have the DH sppt phone #?

Why can’t I connect to site??


Sounds like everything’s good on your end. I’d suggest contacting support (via the web control panel) to see what’s going on.

You may want to peruse the recent chatter on this and the troubleshooting boards too. There’s been some pretty widespread problems like this lately.

My site’s been down over half a dozen times in the past two days, for about an hour a pop, for example.


I tried the web address and I also got the index of your site. So that tells me 2 things, one your website is propogated across the net(meaning it is accessable). and two, your index.html file is not in the correct location for me to see it.
When you ftp to your site, there are several folders displayed. One of these is your domain name. (ex.
All files must be below that folder for anyone to view them via browser.
Odds are you upload all your files to the root folder (sometimes called home directory). So in the field that asks for the location of your site to upload to. You should beable to just add / to the end of that field.


When you FTP to your account, you should see a directory with the same name as your domain, in this case it will be This is the directory that you must upload your website files to.


Edit: Beaten by silkrooster :slight_smile:

Save [color=#CC0000]$50[/color] on DreamHost hosting using promo code [color=#CC0000]SAVEMONEY[/color] ( Click for details )


LOL, Just noticed that myself.


well, there is no directory named “

is DH supposed to create this directory?


DH does not use “public_html” directory?


Okay, I created directory named “” like advised. Still doesn’t work. Argh!


Is the domain listed in the Panel > Manage Domains area? If it is, then you should dontact support becuase something didn’t get set up right when the Domain was created.



Yes, if the domain is fully hosted by DreamHost, then this directory should exist in your home directory.

You can check if the domain is ‘fully hosted’ by looking in Domains -> Manage Domains

No, each domain that is fully hosted will have a directory of the same name in the home directory of the user who controls that domain. This system allows you to host many domains (or sub-domains) under the one user account if required.


Save [color=#CC0000]$50[/color] on DreamHost hosting using promo code [color=#CC0000]SAVEMONEY[/color] ( Click for details )


If you go to Domains -> Manage Domains then click Edit for the domain (in the Web Hosting column), what does it show for the Web Directory: ?


Save [color=#CC0000]$50[/color] on DreamHost hosting using promo code [color=#CC0000]SAVEMONEY[/color] ( Click for details )


What do you mean by “” fully hosted"?


Well, the with any particular domain on DreamHost you have the option for re-directed, mirrored, parked, cloaked or fully hosted.

Fully hosted basically means that you will have a publicly accessible directory for that domain and Apache will serve pages from that directory.

You can determine if the domain is fully hosted by checking Domains -> Manage Domains in the Web Admin Panel. You should see the word ‘fully’ under the Web Hosting column for that domain.


Save [color=#CC0000]$50[/color] on DreamHost hosting using promo code [color=#CC0000]SAVEMONEY[/color] ( Click for details )


Oh, ok.

Now that you told that, I remembered about the wiki and went to take a look, found it: