Can't connect to Dreamweaver tutorial database


#1

I am testing out the MySQL connection in Dreamweaver 2004. I am running through the steps in the Dreamweaver tutorial, making changes necessary to get their test database running on Dreamhost. The DW instructions are Windows server centric.

I got my database set up on the DH panel, not my first MySQL database by the way, so you’d think I’d be able to figure this out. I had to call my new database ykfpmotors, since someone already has used DW’s name TrioMotors, so somebody has probably done this DW tutorial before on DH. I added tables and populated them running DW’s insert.sql script. I can connect to my DW tutorial database with “mysql -u ykfpdata -p -h ykfpmotors.ykfp2.dreamhost.com ykfpmotors”. And I can find my new database with phpAdmin pointed at http://www.ykfp2.dreamhost.com/dh_phpmyadmin/ykfpmotors.ykfp2.dreamhost.com/ . But I can’t get hooked up with DW’s database connector. I get a popup forms titled "MySQL connection, filled in the boxes:
Connection name connTrio
MySql server: ykfpmotors.ykfp2.dreamhost.com
User name ykfpdata
password my password
Database: ykfpmotors but also tried the select button but I get the same result: 503 service not available

You’d think I mistyped something but I’ve gone back over it and also tried setting up the MySQL connection on my Windows XP from Microsoft Data Access- ODBC administrator. I filled out the pop up form to configure my MySQL ODBC 3.5.1 Driver to use Server ykfpmotors.ykfp2.dreamhost.com and user ykfpdata and database ykfpmotors, but testing this I get “Access denied for user: ‘ykfpdata@host10.yakama.com’ (Using password: YES)”

Where is my typo?


#2

Is dreamweaver running from dreamhost or on your own machine? if it’s on your own machine you need to edit your mySQL user to be able to access the database from outside dreamhost. (go to your panel, goodies, mySQL, then modify the user)

-Jason

MP3Mystic Your personal Streaming MP3 Server
Dreamhost Hosting


#3

I think that’s it. I vaguely remember doing that with my other databases, and took a look from the Panel what hosts are allowed on my other databases. Then set the new one to allow connections from the same IP range. Do you have to answer this question a lot from those of us that forgot this detail of your MySql implementation? Does it take 5 - 10 minutes for the change to take effect?


#4

I only suggested it because I just set one of my databases up for remote access myself, and I had to do it (there is another topic that mentioned it in the last few days).

When I did it the change was instantanious.

-Jason

MP3Mystic Your personal Streaming MP3 Server
Dreamhost Hosting


#5

I went to the Panel and added 207.66.242.% to the host list, then tested it with ODBC Data Source Administrator and I got
"Access denied for user: 'ykfpdata@207.66.242.%"

So I went to the Panel and added %, then tested it and got “Access denied for user: 'ykfpdata@%”

I also tried a new password for ykfpdata, one strictly alphanumeric.


#6

this thread might help.

http://discussion.dreamhost.com/showflat.pl?Cat=&Board=3rdparty&Number=13736&page=&view=&sb=&o=&vc=1


#7

Just tested ODBC myself and it worked. let me create a test user for you. Il send you a PM

-Jason

MP3Mystic Your personal Streaming MP3 Server
Dreamhost Hosting


#8

Well, now my ODBC connection works from my XP to my new MySQL database, even before I changed the host name. It’s just that it took about 1.5 hours to get set up, rather than 10-15 minutes.

Now the problem is isolated to the Dreamweaver setup. I also tried a DW connection to my previously existing DH MySQL database. Just as with the DW test database, it appears the initial files get ftped but then I get a 503 error. It looks like there are other forum posts on Dreamweaver, so I’ll be looking at them.


#9

That was probably the time it takes for the name to propogate accross DNS servers.

-Jason

MP3Mystic Your personal Streaming MP3 Server
Dreamhost Hosting


#10

That, and it also happened that there was a MySQL outage that day, later announced by email by DH.

Still after a couple of days of working on this, I still can’t get this Dreamweaver Database Dialog to work with DH. I’ve set up DW’s tutorial database on DH, and also tried to connect with a previously existing database. But all I ever get is a 503 error from the DW dialog. I hope I don’t have to pay for a call to DW support to figure this out.


#11

is your Connection folder and the _mmServerScripts on your server?


#12

I don’t know about that. How to I check?

I just found out that DW gives me two free “Getting Started” requests to their Support, so maybe I’ll find out something from them soon.

My test database is now at ykfpmotors.ykfp.org.


#13

do you have access to a basic ftp…ie wsftp (durn, I don’t know the names of pc ftps, but I use fetch.) If you can look at what is on your server, you can see if the mmServerScripts and the (connection folder) is on your server. If you want, I can call you. I use dreamweaver with my databases and have no issues. Plus, I have free long distance…anything to help out a dreamhost user would rock my world : )

Just let me know. you can send a pvt message.

Barbara


#14

I got this working last night, but didnt have a chance to get print screens and stuff of the settings. Make sure your site map is set up correctly. Especialy the Paths, and URL, it needs to be correct in two places.

Dreamweaver tries to copy mySQL access scripts to the server, then it tries to access them via the url youve entered. I know in my case the url it automatically generated had an extra directory in it (the mydomain.com directory that dreamhost creates).

-Jason

MP3Mystic Your personal Streaming MP3 Server
Dreamhost Hosting


#15

Sure, I can use ftp, but when you are saying “see if the mmServerScripts and the (connection folder) is on your server” do you mean by my server my Dreamhost server? If it’s DH, I could also telnet in and navigate around in UNIX, my native tongue.


#16

Jason -
Do you suppose it’s the URL in the DW test server set up? What’s that URL supposed to be pointing at? It’s currently set on http://kiki.dreamhost.com/ykfp.org/ Could be the kiki.dreamhost.com is unnecessary since my registered site root is just the http://ykfp.org part.

I’ve used the previous version of DW for a couple years and the DW ftp has been working fine to get and put html content. Now that I upgraded to DW 2004, the site definitions seemed to migrate correctly and I’m still getting and putting fine. When the Connection Dialog attempts to connect, it looks like files get transferred, because I see a couple progress boxes, yet after those files run, I get the 503 error.


#17

I checked my DH website and there is a _mmServerScripts directory:

kiki:~/ykfp.org/_mmServerScripts> ls -lt
total 16
-rw-r–r-- 1 ykfpdata pg106956 10265 Feb 28 10:39 mysql.php
-rw-r–r-- 1 ykfpdata pg106956 2062 Feb 28 10:39 MMHTTPDB.php


#18

I tried the Connection Dialog today only to get a screen capture of the error message, but it successfully connected. I don’t know what has changed. I guess I can continue with the tutorial now. Did DH change something? Has my FTP connection been too slow?