Can't Change CHMOD


#1

I’m trying to change the CHMOD on some of my files, but it won’t change!

I’m using CuteFTP, and I’m logged in as the owner of the files (it says so on the far right), and I right-click and select “Properties” and change the CHMOD checkboxes and hit “apply” then “ok”, but it doesn’t actually change the CHMOD. If I go back to properties, it’s the same as it was originally.

Not sure what else to do.


#2

I’ve never had luck doing a chmod through my ftp client. I always have needed to connect through a terminal client. PuTTY is a very good free client that supports ssh and telnet. You can get a copy from the author here: http://www.chiark.greenend.org.uk/~sgtatham/putty/

It’s a simple executeable that you don’t have to install. Just select “telnet” connection, enter the host name as you would in your ftp client, and connect on port 23.

Always works for me, but I don’t know enough about CuteFTP to tell if maybe there are settings you have to change.


#3

I have putty (I’ve been using it to install AWstats), but I have no idea how to change CHMOD on it.

FTP changing CHMOD has always worked for me before on my site(s) here at DreamHost.

Thanks, though. :slight_smile:


#4

Nevermind, I figured it out! Thanks!


#5

Please share in case someone else runs into this problem. Was it just a matter of executing the right commands through PuTTY, or did you figure out how to chmod in CuteFTP?