Can't backup DB: mysqldump always killed


#1

Hello all,
I’m currently unable to backup my MySql DB because the mysqldump process is always killed before completion. I had the same problem in the past and searching the forum I found the suggestion to renice the command with ‘nice -n 19’ and this worked for some time, but now it gets killed even if I use nice. The DB size is currently 33 MB and slowly growing, but it doesn’t seem huge to me.
The possibility to dump the DB is an absolute must for me, and I can’t believe I’m the only one having this problem.
Is there another way to backup the DB?


#2

Most process are currently re-niced by procwatch, so there’s really no need for that. You might want to check the Control Panel though and see if there’s a suggestion to add mysqldump to procwatch’s “whitelist”. I believe someone in IRC mentioned this yesterday, so you aren’t alone at least :wink:

Your other option though, would be to break the dumps up into smaller pieces. There might even be some programs available on the internet to do that for you.


#3

At what time are you doing your bk? I do at 00 hrs… every day on 2 DB of more or less same size, 33 and 35MB… and haven’t had troubles (by the way, dump runs at 00 and other 15 minutes later)

ah and that is server time not my current offset.

Regards.


use VICM3 for a full 97USD discount on your first year!


#4

I’m running the dump at 03.15, but I have tried manually at several different times with no luck. I will try submitting a ticket and hope they can offer a solution because this is a serious issue for me. It’s funny being limited to a DB of 30 MB having more than 2 TB available (of which I’m using 0.1%).


#5

Well, it seems I have found a solution. When I went to submit the ticket for mysql issue I saw a tip suggesting the possibility of mysql acces from external hosts. I’ve just tried running the dump from my PC and it works! I didn’t know I could access the DB remotely. Ok, now this setup is even better than before for me :-).


#6

Thanks for sharing that! I can’t believe I didn’t think of that solution immediately when I saw your posted question.

The ability to connect to the DB from your own machine does rock, and opens up a lot of great functionality, and provides a work-around for a lot of issues. :slight_smile:

–rlparker


#7

True!
It could be worth to mention that remote access must be enabled in your MySql configuration (it’s done via control panel).


#8

For my backups, I use mysqldump (up to 20 Megs) all the time at all hours and have not had a problem. I then rsync my entire account from my home computer to keep a local backup.

Not that that’s much of a help, but I’ve just not encountered the process ever getting killed.

-Scott


#9

I use mysqldump to backup a mysql database of 400MB easily at 12pm everyday, I’m just in the process of testing whether all the data is there, but I’m pretty sure it works!