Can's send email using RoundCube

apps

#1

I’ve been working on installing RoundCube. Tried once, deleted it. Tried twice, deleted it. Third times a charm and I’m not even sure what I did to finally get it working.

The one problem I’m still having is that I can’t send email using RoundCube. I’ve tried the SMTP port at 25, 587 and 465 but I still can’t send.

Here are my configs (names have been changed to protect the innocent):

$rcmail_config[‘enable_caching’] = FALSE;
$rcmail_config[‘message_cache_lifetime’] = ‘10d’;
$rcmail_config[‘auto_create_user’] = TRUE;
$rcmail_config[‘default_host’] = ‘mail.example.com’;
$rcmail_config[‘default_port’] = 143;
$rcmail_config[‘username_domain’] = ‘example.com’;
$rcmail_config[‘mail_domain’] = ‘’;
$rcmail_config[‘virtuser_file’] = ‘’;
$rcmail_config[‘virtuser_query’] = ‘’;
$rcmail_config[‘smtp_server’] = ‘mail.example.com’;
$rcmail_config[‘smtp_port’] = 25;
$rcmail_config[‘smtp_user’] = ‘%u’;
$rcmail_config[‘smtp_pass’] = ‘%p’;
$rcmail_config[‘smtp_auth_type’] = ‘’;
$rcmail_config[‘smtp_helo_host’] = ‘’;
$rcmail_config[‘smtp_log’] = TRUE;
$rcmail_config[‘session_lifetime’] = 30;

Anybody have any ideas?
Also, does anybody know what I can do so that the sender field (when I compose a message) automatically fills in with the users address?


#2

My money is on this line:

$rcmail_config[‘smtp_auth_type’] = ‘’;

I’m guessing that it should be set to ‘LOGIN’ - I’d suspect that without an auth type, you’d not log into the SMTP server to send mail.

$rcmail_config[‘smtp_auth_type’] = ‘LOGIN’;

Just guessing though, I’ve not tried it - or roundcube.

Wholly - Use promo code WhollyMindless for full 97$ credit. Let me know if you want something else!